Plasma 6 X11 - compositor seems to no longer work?

Currently I’ve been using Fedora KDE since April. Upgrade from 39 to 40 went smoothly, all I needed to do was reinstall X11, because I’m using Nvidia GPU. The system was working fine until yesterday when I started having issues with it. What may have triggered it was me uninstalling a Windows application in Lutris, the first odd occurrence was that the trash bin icon on desktop vanished afterwards. I have ended desktop session and logged in again, and suddenly I started receiving KWin-X11 errors from abrt, and my desktop looked like it was on software rendering - all animations and floating panel’s transparency were gone. I rebooted the system, and nothing changed - abrt gave me errors from different applications, like plasma-workspace and qt, where they all had unexpected shutdowns. On the compositor settings, there was a window saying that the compositor turned off OpenGL rendering due to possible driver issues, with an option to re-enable it, but when I do nothing happens. Honestly I could get by like this, but unfortunately Steam displays only a black window.

I believe that kwin had a new version update yesterday, so I’m unsure if it’s the update’s fault. Rebooting the system does nothing. Wayland works, but unusable for me due to lack of explicit sync support from Nvidia as of yet. Honestly I’m at a loss.

System info:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.0
Kernel Version: 6.8.9-300.fc40.x86_64 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5800X3D 8-Core Processor
Memory: 31.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3070/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: B550M GAMING

Good to hear that Wayland works fine.

Kwin-x11 is unmaintained since some time ago, keep that in mind.

But for now, didnt you have any BTRFS snapshots you can boot in? Or are these just older kernel versions?

I didnt use traditional Fedora long.

Display the dnf history and try reverting back the kwin version.

I would advise using Lutris Flatpak, such a thing would never happen there.

I have a bad feeling about running Windows stuff with so much access.

You said it yourself, if it wasnt the update, some random uninstall broke things.

Also try to reinstall the NVIDIA drivers from the terminal. There is likely a DNF option to do that.

Hi, thanks for replying. I just checked out r/Fedora on Reddit, and there are more people having this exact same issue. A recent update may have broken X11 on Plasma 6.

But for now, didnt you have any BTRFS snapshots you can boot in? Or are these just older kernel versions?

Sorry, I haven’t created any snapshots. The only old kernel I have is 6.8.8. I have upgraded to F40 late, only last week.

Display the dnf history and try reverting back the kwin version.

I will attempt downgrading kwin in a moment. dnf history does not display updates, possibly because I have used Discover to do that.

I would advise using Lutris Flatpak, such a thing would never happen there.

It’s the Fedora build. I believe now that it was not the cause, but the KWin update.

Also try to reinstall the NVIDIA drivers from the terminal. There is likely a DNF option to do that.

I have tried that, following RPM Fusion instructions. Rebooting after uninstall, then reinstalling and rebooting again. Did not work.

I can recommend Fedora Kinoite, where this would be easily reversible.

You can install Fedoras official version and then rebase to uBlue kinoite.

I wonder if there is a F40 uBlue image with X11 stuff included, that would totally make sense.


But to the point

As Discover did that, search something in pkcon --help

pkcon repair might help

sudo dnf downgrade PACKAGENAME is also possible

Search for the packagenames here

rpm -qa | grep nvidia

I have reverted KWin dnf downgrade kwin-x11 and the compositor started working again.

2 Likes

This sounds like a perfect time to file a bug against that package.

2 Likes

I was about to, but it’s already been done:

https://bugzilla.redhat.com/show_bug.cgi?id=2280852
https://bugs.kde.org/show_bug.cgi?id=487098

So far Fedora is the only system reporting it.

2 Likes

@yellowdog Thanks for that. I ended up here for the same exact reason. It’s really super-frustrating that Wayland is being figuratively shoved down our throats when it’s STILL no where near ready. I’m happy to see Wayland being worked on as an X11 replacement, but that’s where its at, being worked on. I cannot use it for many reasons I won’t go in to. Hopefully this gets fixed and I can update again soon.

2 Likes

Looks like it’s fixed: 2280899 – Compositor does not work after newest base KWin update

Installed and verified. WHEW! Let’s hope this is not portentous in any way. :slight_smile:

1 Like

I know this has a solution, so I want to add that your GPU does have Wayland support if you need to in the future.

1 Like

Well, it turns out this WAS portentous after all. X11 is working but I cannot play any DXVK/VKD3D games any longer as X11 now crashes after the Plasma 6.1 update. This is super frustrating…

I mean super frustrating, I cannot play my games today and that is all I want to do. …WHY???

shakes fists at the gods

Wayland is still not working?

No, of course not. Wayland is still a train-wreck as far as I am concerned. :worried:

Update: I will not go into why here as it doesn’t matter. I have a huge list of reason’s why I cannot use wayland.

Might want to switch to RHEL then, it is free for some devices.

I managed to capture the log of it crashing but I cannot find the reason.

I’ll keep digging through this and see if I can find the actual source. For now, I did find that disabling the compositor fixes the problem…of course.