Pinebook Pro Fedora32 on SD

Fedora32 on SD during upgrade to Fedora33 communicates with emmc/Boot_Manjaro DTB. Why does it do this, and does it mean it can never run independently and/or never run on emmc or PCIe M2 drive?

Welcome to the community @glennjot

Please have a look #start-here first. It shows what kind of information is needed to help you.
A good idea would might bee running the command inxi -Fzx in terminal and post us the output.

About your question I have to guess. Fedora updater is looking for other OS’es installed and tries them to include in the boot menu. This means you will be able to boot from your Fedora SD direct Manjaro if it is correct configured. If you don’t want this you might have to unmount the emmc before making the upgrade.

As I mentioned, with more info’s more people will participate to helping you :wink:

I like linux ,too.

Thanks for your assistance.

I tried that, and it did not work. That produced a kernel panic when I tried to boot the upgraded Fedora. Since Fedora then does not come up, I cannot open terminal and inxi -Fzx.

I had Fedora33 up and was trying to add ClamAV (ClamTK did not work didn’t work, but I could run it on the teminal) and Tor (did not work) when I first saw updates attempting to post to to Boot_Manjaro DTB. If this is a hardware malfuntion, it is a very odd one.

If it were a firmware malfunction, a restoring The SD should fix it. The restored Fedora32 comes up, but the upgrade tries (and fails) writing to Boot_Manjaro DTB, and the upgrade fails.

Same on a fresh Sandisk 64GB SD.

I haven’t done much of anything with the emmc/Manjaro KDE but change settings (bigger fonts).

Any Thoughts? I may try SD/Manjaro xfce and see if the same problem occuers

Note-I actually switched off the emmc with the hardware switch, if it matters. glenjot

sudo dnf install inxi

Did you check on Pinebooks community if the problem is known?
Or on Manjaros page?

Is maybe secure boot something you have to switch of in bios ?

Hi fedora folks-

I reloaded fedora and recreated the error, without the upgrade, and next boot up just added clamav which seemed ok

but after and lmsensors I got

DWMC rockchip fe32000 error -110 requesting status
mmcblc1 recovery failed
system journal id [676]

blk id request
blk update request: I/O error dev mmcblk1 sector 1764097 op 0x0:read flags 0x0 phys_seg1 prio class 0

blk.update_request [676]: I/O error dev mmcblk sector 17604095 op 0x0:(read) flags 0x0:(read) prio class 0

system journal id[676] failed to write entry (9 items 246 bytes) ignoring read only file system

which I wrote down by hand. I have interpreted mmcblk1 as BOOT_FEDORA -

maybe you have another interpretation?

Hope so, let me know-

Thanks, glenjot

Thanks for your attention,

Hi Fedora Folks-

Problem was sudo did not actually give me full root privilege, as it should.
I don’t know if this should be considered a bug or a feature,

perhaps it corresponds to corporation rolls in Red Hat.

Either way the solution is to log in as root to make any system change,
and a prominent warning should be posted on the download link.

Beyond that, I like Fedora, and am glad the effort is being made to support this hardware,