Pidgin messenger not working with Fedora 34

Pidgin does not seem to work with upgrading Fedora 33 to Fedora 34. I tried to build it from source but ran into dependency issues that did not seem worth it. Does anyone else have this problem?

1 Like

When you get such a message there is a link to “more details”, and that is what says what the problem is. Please past this “more details” as </> preformated thext.


I don’t see a bug yet that looks linked to this issue yet:

Pidgin on Fedora Bugzilla

It may be worth creating a new user to see if Pidgin works there in case some user configs changed in the new versions installed by the upgrade.



Thanks I will give this a try.

Update: It failed even with a brand new user.

1 Like

I couldn’t copy “more details” to formatted text except line by line, so I just took a screenshot:

This is the error I get when I try to run form terminal:

I installed from flatpak and the problem seems to be solved.

I know it doesn’t help you much, but pidgin seems to work fine for me after upgrading to Fedora 34. Btw, I also have one of those error messages from your screenshot, but not the segfault:

$ pidgin
Gtk-Message: 19:34:20.240: Failed to load module "canberra-gtk-module"
Gtk-Message: 19:34:20.240: Failed to load module "pk-gtk-module"
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

However I don’t have your “Couldn’t create plugins dir” message, so maybe there’s an issue with permissions or SELinux context?


@fasulia Thank you for the suggestions. I tried turning SELinux off but this did not solve the problem. I even tried a fresh install of Fedora 34 since I was having other issues and it still crashes.

Do you have abrt installed? It should try to report a bug for the crash on your behalf.

1 Like

Maybe just check for the existence of ~/.purple and ~/.purple/plugins, and their permissions and SELinux context with ls -laZ.

1 Like

I tried “setenforce 0” then running pidgin. It still gives the same crash so it does not seem to be SELinux.
.purple and .purple/plugins both exist with 700 permissions and user/group set to my username.

I did use ABRT to submit a bug report. It is now Bug 1955381 on bugzilla.

Someone else seems to have the same issue:

If I run “pidgin” from command line, it does not help to say why there is a crash:

1 Like

Are you using Wayland? I’m on Xorg. A comment in that bug report suggested this could be relevant.

You could also try contacting pidgin developers on IRC as they’re pretty responsive.

1 Like

Yes it is Wayland. It seems Wayland is the source of the problem now (pidgin works with X11). Also Wayland seems to have been causing Fedora to hang when I switch users. I have switched back to X11 and everything is fine now. Thanks all.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.