Php xdebug not working

I am trying to install xdebug but I can’t make it work and something very strange is happening: phpinfo () says xdebug is not installed. However the listing generated by the php -m command says xdebug is installed.
Any suggestion?

You need to provide more information. What is your PHP and Xdebug version. Nevertheless, make sure you have specified zend_extension=/path/to/ added to your php.ini or another ini file you create in /etc/php.d path.
If still it is not showing up, then add other options to the ini like xdebug.remote_enable and xdebug.remote_host. For more information see Xdebug: Documentation » Installation

Thank you, powergame!
I’ve tried just about everything I found searching the Net. Nothing worked. Finally, I installed XAMPP for Linux and easily got xdebug to work.

1 Like

If php --modules or php --version reports about xdebug, and not your phpinfo page, this probably means you forget to restart the php-fpm service to load newly installed extensions.