Permission denied - transmissiom-deamon

I installed transmission-deamon from Fedora repository, I changed in default settings.json paths where it should download files and watch directories. From standard to custom:

I run default:
systemctl start transmission-deamon

But in journal I have got errors (not only with watch dir but with other above also)
watchdir:inotify Failed to setup watchdir “/home/someuser/transmission/watch”: Permission denied (13) (watchdir-inotify.c:175)

So I checked system init script and systemd is setting (UID and GID) owner as transmission to transmission-daemon PID. So I changed group owner of above directories to transmission, that not helps so I changed also a owner to transmission. It also did not work. So I changed directories rights to 777, did not helped. My second though was, maybe it fails because of selinux so I temporarily changed enforcing to 0. This doesn’t work also.
I run out of ideas what is the problem.

1 Like

You need provide the access permissions to every parent directory using one of the following methods:

sudo chmod o+X /path /path/to
sudo setfacl -m u:transmission:--X /path /path/to

Then make sure the limited user can access the target directory:

sudo -u transmission -g transmission stat /path/to/dir

It worked but I have to change second command to:

setfacl -m "u:transmission:--X" /path
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.