Permission denied as root


I heard that the root account should have all the permissions but this happened when I tried searching for a file. What is happening and how can I gain permission here?

Thanks so much!

Those are mount points that are mounted by fuse. I believe that fuse restricts those mounts to your user account.

Just run the command as your normal user instead of root. That being said, you aren’t going to find the file you are looking for in those directories or any other.

I feel like you are following some bad tutorial. What are you actually trying to do?

I see… Well I am just practicing find and locate commands. This tutorial gives an example of this “ifcfg-enp2s0” file with “enp2s0” part found from ifconfig. Somehow the file doesn’t exist in my system, but the tutorial video was made a long time ago and that might be why some things could be different now…

Is there any resource you could recommend for learning Linux? Like online lectures, Youtube videos, or books. I am currently following some random Youtube tutorials and a course on Udemy. My goal is to learn back-end development and I wanted to have some knowledge on Linux first.

Thanks so much!

Yes, exactly. The network configuration information is mostly in files in the directory /etc/NetworkManager/system-connections

I see… Yeah the guy said that the file should be in network-scripts directory…

That is the old way. It may still work, but NetworkManager is the standard way on Fedora and has been for a long time now.

A lot of things have changed over the past 10 years or so. Things you find on youtube may have worked for that user on the OS he was using & at the time the video was created but may not work now even on the same OS. Things are in a constant flux as development in Linux is continuously progressing.

One thing that every user must keep in mind is that the file system glob character * can help if you know part of the file or directory name you are looking for and add that character at the beginning or end or in the middle of the string you want to find.

I see… Yeah the video looked a bit dated… I need to find something more modern I guess… Thanks