Permanently disable ipv6 for a network device

My log gets filled up with this when I am connected to a vpn:

NetworkManager[1360]: <warn> [1686317300.4276] platform-linux: do-add-ip6-address[3: fe80::390f:5ae1:6b7c:a386]: failure 13 (Permission denied)

This fixes the issue: nmcli d modify wlp114s0 ipv6.method "disabled"

but every time i reboot the setting has reverted and the line starts showing up in log again.

If you are running F38 or F37 it seems likely that the setting in gnome settings β†’ network would be better for that. There is an option there to turn off IPv6 for the interface.

gah, thanks, that seems to have fixed it.

I’d forgotten that sometimes things can be done simply through the UI.

1 Like