[Partially solved] Trying to make doing music work on Fedora Silverblue (VSTs x Reaper x Carla)

Hello everyone,

I’m driving Silverblue for about two months now and I’m lovin’ it… generally speaking. Most things work, even some light gaming through Steam works.

The problem I have is trying to set up my station for music production. Alright, so Reaper doesn’t have a Flatpak version, but it runs directly from the executable, so that’s fine. Everything that comes with it (i.e. plugins, effects, themes, options) seems to work. Recognizes my audio interface, and is just a great experience overall.

However I’m unable to make it see and use VSTs.

Tried opening a Toolbox, installing yabridge (GitHub - robbert-vdh/yabridge: A modern and transparent way to use Windows VST2 and VST3 plugins on Linux) and converting the VSTs with yabridge, which was a straightforward operation (it converted all VSTs’ .dlls into .so files). Though, it says that it cannot find the Wine prefix (this is a side question: I have Windows VSTs installed with Bottles. yabridge has a way to set the wine prefix. Is it possible to set a bottle’s wine prefix somehow and this actually be usable?!)

However, when I point Reaper to the folder where converted VSTs are located, it still doesn’t see them. My assumption is that the problem is being sandboxed.

Then I tried using these VSTs through Carla (KXStudio : Applications : Carla). First, Carla works as Flatpak, it runs, but fails to recognize the VSTs. I then layered it with rpm-ostree, which worked. Did that because I thought that there’s a problem with the contanerisation of the Flatpak. Tried to open those VSTs again, and again a failure. The response I got is:

Failed to load file.

Could not find the VST main entry in the plugin library

Additionally, one of the synths (Vital) has Linux binaries and uses this particular package called libcurl-gnutils which doesn’t exist on Fedora. It exists as a copr, which I added and tried to layer through rpm-ostree, only to be met with:

error: Could not depsolve transaction; 1 problem detected:
 Problem: package libcurl-gnutls-7.82.0-7.fc36.x86_64 requires libcurl(x86-64) >= 7.82.0-7.fc36, but none of the providers can be installed
  - cannot install both libcurl-7.82.0-7.fc36.x86_64 and libcurl-7.82.0-5.fc36.x86_64
  - package libcurl-minimal-7.82.0-7.fc36.x86_64 conflicts with libcurl(x86-64) provided by libcurl-7.82.0-5.fc36.x86_64
  - conflicting requests

but installing it through a Toolbox & dnf works?! Is still unusable by Vital, though.

I’m losing my wits here. Can anyone point me to a possible solution or where to start reading? Why aren’t Carla and/or Reaper able to recognize and use VSTs, and especially, Linux VSTs?

I mean, if I install the Windows version of Reaper in a Bottle and then all the (Windows versions of the) other VSTs, I believe it will work (FL Studio recognizes them, with some graphical issues), but what’s the point in having a Linux binary and OS then? I’d rather find a real solution to this.

Please keep in mind that I’m a beginner in Linux. Any assistance would be very appreciated,

  • A

OK, after fiddling around I partially solved this problem by making sure yabridge and Reaper are run in the toolbox. Now converted VSTs can be discovered and used by Reaper, pretty successfully at that.

I still cannot get Carla to work, but since I don’t need it anymore for bridging I’ll just let it go.

So for anyone wondering how I fixed this:

toolbox enter

then

yabridgectl add "path" [add all paths to Windows VSTs like this]
yabridgectl sync
yabridgectl status [to check status, it should show you all paths and all converted VSTs]

This will populate your home/.vst and home/.vst3 with converted VSTs which can be used under Linux (they will have .so extensions).

Then navigate to Reaper’s dir and run it with

./reaper

Make sure you add .vst and .vst3 dirs in the VST scanning dirs for Reaper (CTRL+P, go to VST). Click on clear cache and rescan.

Voila, now you have working Windows VSTs under Reaper. AFAICT, everything works.

If at any time you add new VSTs, make sure you resync with yabridge and rescan with Reaper. Also, Linux native VSTs should be put in the same two dirs above (but they don’t have to be converted).

  • A