Parental Controls malcontent hides applications in GDM/LightDM/XFCE after upgrade to F37; selecting default display when using Crestron multiple displays

After upgrading to Fedora 37 from Fedora 35 there is no Applications menu at the top. It seems this is replaced in the current Gnome with the Show Applications square.

Clicking on Activities causes the Show Applications square (9 dots in a square at the bottom center) to appear. Clicking on it shows no applications. Using the search box at the top does not turn up any results for “emacs”, “xterm”, or “firefox”.

However when logging in as root user all the applications are shown on the desktop. We’ve tried GDM, LightDM with the XFCE desktop. So does a default Parental Control need to be set up to allow the applications to show?

The F1 console shows the gnome background image. At first, the mouse cursor is nowhere to be found, and there is no login box. Moving the mouse around eventually makes the cursor appear, and on further movement the login box appears. There are customization buttons at top right, including a menu of various session managers, starting with Gnome and Gnome Classic, and ending with Xfce.

Selecting Xfce and the podium is able to send its screen to the Crestron room displays. The default gnome desktop background appears. No mouse cursor at first. Waving the mouse eventually makes it appear. Right-click pops up a menu with items Change Background…Display Settings, and Settings. No menus appear. Using “ps lax | grep xfce” from a console turns up nothing, suggesting that it has used the gnome session manager instead. Indeed, grepping on gnome instead yields several processes, including gnome-session-binary.

As for setting the display, the mouse could go off-screen to the left, suggesting a second hidden display. I opened Display Settings. There are two displays, with the smaller one, identified as 2, chosen. I used the Multiple Displays setting to change Join to Mirror. Or better yet, select display 1 (Crestron) and turn it off. Now the top menu bar appears, with Activities at top left, then Settings; the date and time are in the top center; and the network and power button are at top right. This explains the behavior of the login screen, where the hidden display has the login box and the mouse initially. Moving the mouse rightward into the visible display and then left again causes the hidden display to be used, so the login box appears. This also explains the different behavior of the podium compared to the rest of the machines. They do have a second display but the default one has the login box. So is there a way to set the default so anyone using this workstation will see the desktop as the primary screen on the computer’s monitor which is a Dell All In On 7480?

Edit: I see this thread which means removing Java but it really sounds similar, and distro-sync made no difference

I believe we actually need more info to know the environment usage.

It seems from your description that this may be a classroom environment, and as such is somewhat different than would be expected for home usage.

Additionally there has been significant changes between F35 and F37 so your config is likely out of date with what F37 expects, even for the same apps.

Sure this is a classroom setting where the workstation connected to the podium uses a Crestron switching system which allows pushing out the display to monitors in the room. So that’s the 2nd issue.

The first issue is the applications now showing after logging in as a non-root user.

What configs can I share?

1 Like

First step would be to ensure the PC at the podium is properly booting and displaying everything properly.

The normal admin user (or instructor) should be the one logged it to do that. For your earlier question, yes, parental controls may interfere with what can be displayed depending upon the way it is configured.

I would expect that the config for the parental controls may be at fault for blocking access so that should be the region for you to investigate. Note that I have not worked with any of the parental controls so may not be able to assist in more than a generic way.

Except for all of the applications being hidden and that the mouse is off-screen to the left.

As root user all applications appear.

Any other threads that we can look at? I’ve searched but other than the ones I’ve posted not much seems relevant.

  • But now I also remembered I did change a kernel option, setting nouveau.modeset=0 in /etc/default/grub

  • I installed LightDM along with lightdm-gtk-greeter as noted here .

  • I created a new drop in file, e.g.,/etc/systemd/system/lightdm.service.d/fixes.conf containing:

ExecStartPre=/bin/sleep 5
  • I also installed lightdm-gtk-greeter-settings:
    dnf install lightdm-gtk-greeter-settings

But we’ve tried with GDM too. Could that kernel option be causing this?