Pamd.d Login with U2F setup (yubikey) not working on Fedora 38

Recently I upgraded from Fedora 37 to Fedora 38.
Only problem I noticed was, during the login, it treats my Yubikey entry as a password instead of a U2F entry. So I can only login with my actual password instead of the configured U2F.
So it is ignoring my u2f setup in the pam.d
Interestingly, it only affected login. U2F for sudo and cinnamon-screensaver still work.
The entry that worked in Fedora 37 was made in /etc/pam.d/login

The login u2f entry
auth       include      u2f-sufficient
auth       substack     system-auth
auth       include      postlogin
account    required
account    include      system-auth
password   include      system-auth
# close should be the first session rule
session    required close
session    required
# open should only be followed by sessions to be executed in the user context
session    required open
session    required
session    optional force revoke
session    include      system-auth
session    include      postlogin
-session   optional

I tried looking for changelogs in the docs but couldn’t find a relevant change that might have triggered this.
Are there changes to the Login that require me to setup the u2f in another file?