Optimizing the GNOME environment?

I’m just gonna get straight to the point.
I have a device with some not-so-great specs, and the GNOME environment has a lot of lag at times. I’ve disabled animations, but it’s still fairly laggy at times. Is there anything I can do to solve this?

Note: For some ridiculous reason, using anything other than Fedora 31 Workstation, changing the resolution softbricks the install. I’ve tried every Fedora Spin, and even an Ubuntu ISO that’s supposed to work properly, but they all had the same result.

Edit: Extra (Hardware?) Info, I have a 32-bit UEFI on a 64-bit processor. Fedora is the only distro (I’ve checked) that supports this on a regular ISO.

1 Like

I remove the programs I don’t plan to use. For example, I use dnf for package management, thus I remove PackageKit and gnome-software. If you won’t use virtual machines, you can remove gnome-boxes.

1 Like

You can disable all unnecessary plugins and add-ons, you can also get rid of several unnecessary programs in the environment.

When uninstalling any programs, remember about dependencies (before uninstalling, DNF usually shows which dependencies will be removed in the process), keep it in mind.

Also, note that you are using: Xorg or Wayland. For some hardware this is critical. Change to a more suitable in your case.

At the very beginning, before deleting anything and everything, try switching to Xorg. This is easy to do (if you don’t know how), log out, click on the wheel under the password field, you will have three options. GNOME is used by default (Wayland), but you need to choose GNOME Xorg. Next, log in and use the system. It’s better to restart everything, of course.

P.S: I used to work with Ubuntu for more than 6 years, and I’ll tell you from my experience, that GNOME at Fedora is more optimized and works better.

1 Like

Search how to force disable search/tracker and gnome software service ,disable unneeded(for you) service bluetooth,cups…disable unneeded autostart applications .

Disable animations from gnome-tweaks , disable unneeded gnome extensions .

Use lighte applications.

Didn’t help with the lag, but it appears Xorg may be what causes resolution changing to break. Do you know if Fedora 32 uses Xorg by default?

you are able to choose between X and wayland.
at the graph. login screen - I guess only - after you have choosen the user you will see a wheel

  • for F32: at the right sight
  • for F31: - I believe - under the user name(s))

clicking the wheel you’re able to choose wayland/non-wayland.

regarding limited specs:
if it’s an intel:

and the requirements for clearlinux (!):

Clear Linux seems to be a nearly unusable distro, I’ll try it, but only after everything else fails.

By default in Fedora 31 (and 32), used Wayland. In my case, I use GNOME Xorg, and it works pretty well. Fedora 32 release - 20 May 2020.

Well that theory goes out the window as well. I wonder what causes the resolution bug.

I’m just trying to figure out a probable cause. I’ve come to the same mistake multiple times, but that’s all I can actually do at this point. Continue to try recommendations, and maybe it works out eventually.
Currently about to try Majaro, recommended to me on a reddit thread.
If that doesn’t work, Clear Linux.
If that doesn’t work, then I’ll probably just reinstall Windows 10.
I don’t like Windows 10, and I really don’t like being on a 32-bit version of Windows 10, but that would be the final option.

Neither Manjaro Linux nor Clear Linux worked. Also I realized I never explained the main issue of distros not working in the first place.
The [people] who designed this system, decided to use a 32-bit UEFI for a 64-bit processor. Out of everything I’ve tried (haven’t tried Debian though), only Fedora actually boots from an unmodified ISO. That’s how I eventually ended up here.

While I understand your frustrations, please do not use terms like “idiots” to refer to people in or outside of Fedora. It is not in the spirit of the Code of Conduct: :slight_smile:

My bad, edited the post.
I booted Ubuntu again, and I was actually able to change the resolution to a lower one that was the same aspect ratio, as well as some 4:3 ones. I remember seeing a weird message about aspect ratios in a configuration program on Windows, maybe it has something to do with that? But, it doesn’t explain why I can set a 720p resolution in Fedora 31, but nowhere else.

1 Like