OpenZFS requires proprietary Nvidia packages?

I’m new to Fedora (jumping from Mint) and struggling to get OpenZFS installed… I get no errors when installing, but when I reboot (it is required) my system won’t boot. The issue appears to be due to nvidia drivers being installed as part of the opensfs install… when reviewing the output in the command line I can see it is downloading proprietary nvidia drivers. This is rather confusing to me.

I had the same issue with Mint… when I tried proprietary drivers the system wouldn’t boot.

Is there any way of installing openzfs without requiring the nvidia packages??

I’m following the instructions here… Fedora — OpenZFS documentation

rbrown@bobbyb:~$ rpm-ostree install -y$(rpm --eval "%{dist}").noarch.rpm
Checking out tree e664c15... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora google-chrome rpmfusion-nonfree-nvidia-driver rpmfusion-nonfree-steam updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2023-03-14T10:57:01Z solvables: 4
rpm-md repo 'updates' (cached); generated: 2023-12-31T02:19:05Z solvables: 17311
rpm-md repo 'fedora' (cached); generated: 2023-11-01T00:12:39Z solvables: 70825
rpm-md repo '' (cached); generated: 2023-08-10T15:35:19Z solvables: 5
rpm-md repo 'google-chrome' (cached); generated: 2023-12-20T18:05:54Z solvables: 3
rpm-md repo 'rpmfusion-nonfree-nvidia-driver' (cached); generated: 2023-12-29T17:12:39Z solvables: 29
rpm-md repo 'rpmfusion-nonfree-steam' (cached); generated: 2023-08-10T16:27:35Z solvables: 2
rpm-md repo 'updates-archive' (cached); generated: 2023-12-31T02:42:39Z solvables: 20081
Resolving dependencies... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
Writing OSTree commit... done
Staging deployment... done
Changes queued for next boot. Run "systemctl reboot" to start a reboot

Does that method of installing ZFS trigger the DKMS (dynamic kernel module support)? I think I read that DKMS and ostree systems didn’t get along at one point. I don’t know. I use the normal/traditional Fedora Linux and OpenZFS works fine on it. (But I don’t have the third-party nVidia drivers installed on any of my systems.)

This line means only the metadata has been downloaded and not the actual NVIDIA driver.

What exactly happens when you try to boot.

Is it possible that the zfs kernel modules are causing issues with secure boot? Did you try disabling that?

As @glb pointed out, the method you followed is for Fedora Workstation (not an atomic version like Silverblue) so dynamic kernel module loading is a no go without a live filesystem/alternate approach (akmods?). But just as a thought, can you not select at installation to use ZFS filesystem for a partition and format it as such? I seem to remember the option being there when I check my disk layout prior to beginning install.
[Edit]: Okay I checked the link you provided plus the one for doing this from installation and it is a big amount of work to do this for installation as you cannot select it from the installer. I checked using Fedora Silverblue 39 installing to a Boxes VM, there is no ZFS filesystem option.
From what I have read, this will likely not do well at updates and may not behave nicely with secure boot or LUKS.

Ah! Obviously, immutable OS isn’t going to help!

I switched to Ultramarine instead (not immutable), now trying to install ZFS but get 404 message…

❯ sudo dnf install -y$(rpm --eval "%{dist}").noarch.rpm
[sudo] password for rbrown: 
Last metadata expiration check: 0:04:07 ago on Mon 01 Jan 2024 09:59:19 AM EST.
[MIRROR] zfs-release-2-4.um39.noarch.rpm: Status code: 404 for (IP:                                                  
[MIRROR] zfs-release-2-4.um39.noarch.rpm: Status code: 404 for (IP:                                                  
[MIRROR] zfs-release-2-4.um39.noarch.rpm: Status code: 404 for (IP:                                                  
[MIRROR] zfs-release-2-4.um39.noarch.rpm: Status code: 404 for (IP:                                                  
[FAILED] zfs-release-2-4.um39.noarch.rpm: Status code: 404 for (IP:                                                  
Status code: 404 for (IP:

I tried v 2.2 and that didn’t work either

  1. I am following the official OpenZFS instructions for Fedora here Fedora — OpenZFS documentation … why would the instructions include a hard-coded version??? Perhaps I should ask that question to the OpenZFS community.

  2. I don’t need a bootable ZFS volume; I have a zpool on 2 HDs in my computer that I need to access.

  3. Why is it so hard to get ZFS working on Fedora? I assume the ongoing licensing concern with Oracle… but it shouldn’t be THIS hard to get working. For example on Linux Mint (from where I came) had ZFS enabled by default.

This part won’t work on ultramarine. You should use the appropriate Fedora identifier instead. In this case, “fc39”

1 Like

You are right, this is all about licensing issues with the zfs driver and since Fedora cannot ship it, you need external driver modules.

Fedora is supporting BTRFS, in case this is something you want to try.

Ok thanks everyone for the responses, this is indeed a great community!

Today I stepped back and decided to go with plain Fedora 39 to see if I could get zfs working. I installed no problem and rebooted.

I then followed the install instructions for OpenZFS. Got to the last command without any errors but then the last one modprobe zfs had some complaints. I thought about writing that down, but thought nah I will reboot and then try it again after a reboot.

So I rebooted…

Nothing. Blank screen for 10 mins.

Rebooted. Same. Nothing.

So I do think there’s something up with my hardware, the drivers for the hardware and zfs. I think I will just go try a different distro like debian and see if that succeeds or fails. Shame as I really wanted to give Fedora a try but I’ve been at this for two days with not success :confused:

Thanks all for the help… if I get things working I will report back. ZFS is a show stopper for me.

Getting ZFS to work on Fedora Linux is non-trivial. I have an idea to write a script to make it a little easier for people to try. If I can find the time, I might actually do that one of these days.