Onboard audiochip set to "OFF" after every boot

i have this problem for a while now (dunno some “dnf update” in past and it stopped or so), and decided that me the humble linux artist after sifting through the endless void that is called the Internet to ask here for help, maybe i’m to stupid to ask the right question and build connections between stuff, who knows.

So, i have to manually enable my onboard soundchip (alc 1220 on my X370 k7 by gigabyte) via pavucontrol as it is set to off after every boot

it also shows as default(unavailable) in pavucontrol which oddly works despite the tag.

But it gets annoying after having to manually switch it after every boot and i refuse to go back to pulse, tried media session and wireplumber and the result is still the same.