On upgrading Fedora 31 to 32, can't get sudo to require password

On upgrading Fedora 31 (LXQt version) to 32 on a single-user laptop, the user is no longer prompted for a password when attempting sudo functions or those requiring root privileges. I want the user to return to be prompted for password. For example, performing something like ‘sudo dnf update’ the command is carried out without any prompt or password requirement. Using ‘sudo visudo’ I made some minor edits to the default file such as
Defaults authenticate
which should be defaults anyway, but no luck. Any help appreciated. Other than this, smooth upgrade and great distro!

Hi @kendew and welcome to the forum.

If you compare your /etc/sudoers file to the one we ship, can you see any differences?


Thank you for replying. Looking at the /etc/sudoers file that you ship, I see no discrepancies. The problem may not be in the sudoers file.
On the other hand, when I installed Fedora I was given the opportunity to create a user, and also the opportunity to designate that user as not requiring a password. Pretty new to Fedora, I selected that option, thinking it meant autologin, i.e. not requiring a password to login. Perhaps it meant something else, and, if this was the mistake, I wonder which files I could edit to correct it. I want a password required by any user attempting anything requiring sudo or root privileges.
Another workaround would be simply to eliminate this user and try creating another admin user, but it would be nice to know the source of this problem so as to avoid it in the future.

So, there never was a password set for that user?
In that case, open a terminal and use passwd to set up a password.

Yes, it seems setting passwd in terminal solved the problem. When I created the user I did at first enter a password for that user. Afterwards, I unchecked the box Require a password to use this account thinking would give the user autologin. I was confused as to its meaning, as I’ve installed any number of Linux distros but don’t remember coming across such an option. After reading your reply I became curious, and referenced this doc. In this Anaconda instruction I find " Make sure that the Require a password to use this account check box is enabled…" This leaves me still confused about why the option is there in the first place.
Anyway, I have to thank you again. Now I can use this great distro without that security worry.

1 Like

There was a System-Wide Change proposal for F32, which got rejected by FESCo. There was a LONG discussion about it on devel, if you want to know the reasoning behind the rejection.

Btw, I think you are supposed to mark the thread as “solved” for the sake of others who might be having the same issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.