On-screen keyboard emoji pages inaccessible?

I did a dumb thing. Creating a new test user account, I decided to take advantage of the handy “Enter emoji” context menu option when setting the password, not considering that the same option might not be available on the login screen.

“No worries!”, I thought, “I’ll just enable the handy on-screen keyboard feature; it’s got an emoji input mode!”

Nice idea, except… Well, this is the problem. (Screenshot taken in a VM, since I couldn’t easily get one of the real login screen, but the issue is the same for both):

The emoji I used in the password wasn’t one of the 33 on that first page of choices, and… … … how in hell do I get to the other pages (circled in green) to choose any of the other emoji? There’s no scrollbar or page advance button, and I’ve tried:

  1. Clicking on the little dots; no dice
  2. Repeatedly clicking on the icon for the face emoji set (next to the “ABC” button), to see if it would cycle pages; it will not
  3. Scrolling my mousewheel over the emoji panel; no effect
  4. Clicking and dragging the existing choices leftwards, to simulate a swipe action; completely inert
  5. All manner of attempts to use physical keyboard inputs like PgUp / PgDn, / , etc; all inputs bypass the on-screen keyboard entirely and go to the password field

I cannot find any way to convince the OSK that I’d like to see the list of emojis beyond that first page.

I should note that while I tried scrolling, it was only in the vertical direction. I’m doing this with an actual desktop mouse as my pointing device, one that doesn’t have a tilt wheel, so if the answer is “scroll horizontally to switch pages” then we still have a problem here.

(Obviously I’ll administratively change that account’s password to something without emoji in it, this isn’t about that. It’s just the thing that led me to discover this problem.)

1 Like

the little dots not changing to the next “page” etc sounds like a bug to me—it should work.

1 Like

That’s what I’d have thought as well!

I guess I was mostly looking for confirmation / sanity-check, to make sure I’m not just missing (or doing) something stupid. Don’t need to go opening any bug reports that I end up having to close as invalid. I’m already at four of those for this week, which is like 2 over my limit. And 4 more than I’d prefer.

(Well, i guess that was last week, technically, but just because it’s Monday doesn’t mean I’m looking to get an early start on this week’s quota.)

Also, I couldn’t figure out where I’d even report that bug, since I had no idea where the OSK code lives anymore. But I think i’ve finally found it, js/ui/keyboard.js in the gnome-shell repo.

(Which has a _pageIndicator to render the little dots. One that’s explicitly set non-reactive, so… that’s weird. A clue, Watson?)

        this._pageIndicator = new PageIndicators.PageIndicators(
1 Like

Reported as OSK Emoji picker: No way to switch (sub-)pages with mouse clicks? (#5538) · Issues · GNOME / gnome-shell · GitLab

1 Like