Okular can't open .cbr files


Okular can’t open .cbr files. When I try to open one, it just says “Could not open file:///home/privacyfreak/Books/batmanonedarkknight.cbr.”

Any help would be appreciated

Some cbr files are compressed using rar.

Try installing unrar and libunrar from the rpmfusion nonfree repos.

1 Like

Still gives the same error

Hmm…I just did some testing. It works here. I had to install unrar. libunrar wasn’t enough.

Then close and re-open okular.

I have both installed. I’ve closed and reopened Okular, and also rebootd. Still have the same error though

Can you open it with calibre?

Try opening okular in terminal and see if it outputs there some additional info. Also try flatpacked version from https://flathub.org/apps/details/org.kde.okular

Calibre didn’t work. I was using the Flatpak for Okular. When I reinstalled the ones from the fedora repos, it worked. It opens fine now. Thanks for all the help

Maybe flatpaked version is missing unrar and libunrar, report it in Issues · flathub/org.kde.okular · GitHub.