Odd Network Behavior on Silverblue (Periodic High Latency)

I’m experiencing really odd network behavior on Fedora Silverblue. Internet will cut in and out between extremely slow speeds downwards of 100 B/s for minutes at a time followed by normal speeds for a few minutes. For context I can get as high as 100 Mb/down. The internet never cuts out completely, just slows.

I was using Kinoite and this started happening as soon as I did a clean install of Silverblue a couple days ago. I’ve used Silverblue on this hardware in the past with no problem. It happens on both Ethernet and WiFi and I’ve already tried restarting my router. No other network device on my network has any problems and accessing stuff on the LAN is lightning fast. It’s definitely a Fedora or GNOME issue as I have a laptop running Silverblue and it upgrading from 38.20230823.0 to 38.20230828.0 has caused it to have the same issue.

Not everything has problems. For some reason Steam isn’t affected by this at all, it starts up fast and maintains fast download speeds. Running a ping test to results in minimal latency. I’m able to be in Discord calls and stream YouTube and Spotify just fine. But when I run any command to download updates, try and connect to my VPN (it doesn’t work at all) or try general browsing with Firefox it’s terrible.

I don’t see any phantom programs taking up bandwidth running nethogs. What I do see are applications that are trying to connect to something taking forever to even appear in the the list. This image demonstrates what I’m talking about, Discord was trying to open for 1:27 at that point and nothing showed up for it in the list ( is a local network device). It seems like once a connection is established everything is fine, but initially starting that connection takes ages.


--- ping statistics ---
672 packets transmitted, 672 received, 0% packet loss, time 671907ms
rtt min/avg/max/mdev = 1.844/2.139/23.667/1.262 ms


07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 26)
08:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

Just rebased to Fedora 39 on my laptop and it doesn’t seem to have the same issue so far. I would do the same on my main computer but my second display was bugging out (couldn’t rotate or adjust it’s position in gnome settings).

Edit: Spoke too soon. Seems to have the same problem. Can be hard to pinpoint since the network will work fine at times.

If you’re sure nothing else in your network is having similar problems, I would say there’s either an issue with resolved or your routes (since you have two interfaces).
Here’s what I would check first:

  • If you have wired and wireless at the same time, the command “ip route” should show you two “default” with different metrics. If they have the same metric, disconnect one of the interfaces, and see if that makes any difference.
  • Running “resolvectl” will tell you which DNS server it’s using. If you see the wrong server there, then your DHCP is giving you a bad DNS server. If you see the expected address there, I would try a clean /etc/resolv.conf pointing directly to that DNS and see if by any chance resolved is getting in the way.

Good luck!

Switching DNS servers fixed it, thanks! Not sure why I only noticed it on my computer and laptop and not my phone.

Hello @aaron5 ,
Good to hear you have solved the issue. Could you please mark the solution comment that helped you?