Odd black frame around some windows in gnome 44 on F38

Recently I have been having an issue with an odd black frame appearing around some windows in gnome 44 on F38 kernel 6.2.13.

The frame looks like this:


If the application is in fullscreen, the frame is no longer visible.

So far I have seen this with 3 applications. One installed via flatpak, one via external repo and one via distrobox on debian.

Got the same issue on Fedora 38 Budgie, where this happens to the Nemo filemanager window.

It started for me with the mutter-44.1-1 update on the 28/4, which broke several themes like Graphite, Orchis & Qogir and probably many others. There were issues on the previous mutter version to, the black frame was not there, but noticed i had to click very far outside the window border, to activate any window below the Nemo filemanager window.

The reason i think its caused by mutter, is that i tested the the mutter-44.1-1 update, the night before it was pushed with the F38 system updates, but had to roll back because of this issue.

On Budige i am now using the default Materia theme without any issues.

I’m seeing the same issue here too. I’m running Fedora 38 / Gnome 44. The timing shared by boxjellyfish lines up with my experience as well.

Starting today, the issue seems to fix itself when I lock the screen or let the system go to sleep, but it’s only one program at a time. At the moment I’ve seen the issue in Steam / Steam games, Signal, and Librewolf. The most persistent one is Signal, even when it automagically fixes itself it will come back if you re-launch the program where the others do not (so far).

It has now gotten worse.
Now the UI buttons in the applications that are affected by this no longer work.


It seems like at least with flatpak the issue happens when an application is running via XWayland/X11 and not Wayland directly.


This is definitely the issue.

There are also mouse issue where these black box are so only on xwayland app. you can’t click trough around

Someone on Matrix was having this issue - removing all the theming config fixed it, so I suspect that will be your solution too.

I’ve already tried to go back to default themes but the issue still happens

Not go back to default themes - completely remove the config.

I went back in the chat log and the user "unlinked the ~/.config/gtk-"* (I assume this is where it’s placed) which fixed the issue (they also tried just switching back to Adwaita and had the issue still).

Generally, if you’re getting graphical “weirdness” with Gnome, blowing away all extensions and custom theme config is the first step (in the Extensions app there is a toggle for disabling extensions which makes that part easy). Then raise a bug with the theme/extension provider.


In addition to black frames, I also have glitches like this on top of my applications. Does this happen to you too?

The glitch turns the black frames into portions of my wallpaper.

Here is another report of the same problem/solution:


It’s worth noting that Gnome Extensions/Themes/etc are more like monkey-patching that’s possible because the Gnome devs don’t lock it down.

That’s not to say you shouldn’t do it, but that if you have a problem the first thing you should expect to do is to delete it all and see if it’s still broken.

I managed to get rid of it by uninstalling and reinstalling my theme with gnome-themes-extra and gtk-murrine-engine

It’s now working fine… grabbing window are now more near from the window at least it’s just a few mm more now.

1 Like

Nuking my .config/gtk4.0 and .themes did the trick. Does this mean the issue is with the theme I was running or an unpatched bug in Gnome 44?

Technically Gnome doesn’t support themes, so there’s no such thing as a bug in a Gnome theme :slight_smile: I would follow up with the theme’s developer.