Nvidia x server doesn't run when I click on it

I’m using Fedora 34 Workstation, Wayland on a Lenovo ideapad 520,
tried to install nvidia drivers (and cuda), but can’t switch to the Nvidia card (still running on Intel GPU)
Also, Nvidia x server doesn’t run when I click on it, other than that, I tried to run nvidia-settings in terminal but got “ERROR: Unable to find display on any available system”.
Sorry for English

Thanks for reply.
Could you please tell me which display server(s) does Nvidia support?

How did you install the nvidia drivers?
Did you reboot after the install?

The easiest way I know is that found by the copr repo here.

BTW, the nvidia x-server cannot run without the driver active.


Installed KDE and it’s running. Thank you very much!

Thanks for the reply.
I think, as it was mentioned in another reply, the problem was with wayland. I installed KDE and now Nvidia driver is operating.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.