Nvidia/Wayland/F36: Some apps’ windows are scrambled

Fedora Settings, Visual Studio Code, Slack, and Google Chrome produce unreadably garbled windows.

A screenshot of Fedora Settings is attached:

I was able to find a workaround for Google Chrome: start from the command line as, e.g.,

$ /usr/bin/google-chrome --enable-features=UseOzonePlatform --ozone-platform=wayland >> ~/chrome.log 2>&1 &

Microsoft Teams does not appear at all, though the icon appears in the bottom task bar.

This is not a complete list; I have not tested every app. However, the ones I actually like to use (Emacs, Frescobaldi, LibreOffice) seem to be OK.

The problem seems to be related to Wayland.

I’m currently setting things up to do a fresh install of F36 (instead of the update I did a few days ago).

If anyone has any hints, I’d love to hear them; otherwise, I’ll be back in a few days to report on the fresh install.


System specs:

Graphics:1080 Ti
CPU: Ryzen Threadripper 1950X
RAM: 128 GB
MB: MSI X399 Gaming PRO Carbon AC

1 Like

im having the same issue although its affecting both xorg and wayland, are you using the proprietary nvidia driver?

Yes; I had the same problems with the default driver, so I switched.

And I haven’t been able to get xorg to work at all since I upgraded.

The default driver doesn’t give the scrambling for me, but it really suffers with performance, i think this is purely a f36 issue because I’ve never had this on f35.

When I could actually see Fedora Settings, I saw that it indicated “Software Rendering,” which one never wants to see. It was really slow.

All the apps that actually work are speedy now …

after some fiddling, i got the graphical issues to go away, did you install the driver from the software center or the “NVIDIA_DRIVER_XXX.run” file from nvidia’s website, as i found the one from nvidia’s website works perfectly on both wayland and xorg, and the one from the software center has some issues it seems

I’ve tried the three most recent versions; none of them give me xorg and all of them have the scrambling on some apps:


even after installing and rebooting are you stuck in software rendering?

I don’t think so, but I can’t see the settings. I’m sure there’s a command-line equivalent, but I haven’t looked for it yet.

The performance is better enough that I think it’s unlikely that software rendering is still in play.

The clean install helped matters. I still get the scrambled windows in Wayland, but X11 seems solid.

I’ll try to move to Wayland in a few days or weeks …

1 Like