Nvidia Prime not showing Fedora 33

I installed Fedora 33 2 days ago, it’s working fine, but I can’t seem to select intel gpu as my main. the option isn’t even there, prime offloading is working but I can’t select either gpu.
I installed the driver from RPM Fusion but it didn’t work correctly ( there were no powermizer or thermal options in the nvidia-settings panel) so I removed it and downloaded the driver from Nvidia.
this one is showing the gpu info with power settings and all but still no prime option !!!

I tried both 455 and 460 drivers, I switched to X11, I removed the driver and installed it again, I reinstalled Fedora twice!! please help
I only need the iGPU.

If there is no powermizer, or thermal option it probably means you have miss-installed the rpmfusion driver. nvidia-bug-report.sh would have been awaited to , but now that
Powermizer and thermal are working fine with me.

What are you calling the “prime option” ?

iGPU is what you have by default (unless using dedicated card using the menu for any application).