Nvidia Optimus card in F36 after Bumblebee repo is no more available

Hi folks,

I have an old laptop that had been working really fine.
It has a Geforce GT 630M card and has Nvidia Optimus.
But after I updated to F36, I realized that Bumblebee repo is no more maintained and there is no repo for F36.
I’d like to have a help to solve the issue, once the computer keeps at 80ºC when there is no work load, where the normal would be between 50ºC and 60ºC.

I have been using KDE X11.
Below more information about the discrete and integrated GPU

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M/630M/635M/640M LE] (rev a1)


Welcome to ask.fedora @jno-zrc

Have you had a look on this?

I had, but I sincerely don’t know for sure if there is a section there that applies to my case.
Actually, I don’t think they do.

Bumblebee is not used anymore.

You just need to install the nvidia driver and understand what kind of config you want/need.

1 - Hybrid mode = Use Intel as main one and ask applications to use the Nvidia graphics when needed
2 - Full Nvidia mode = Ask the X11 ( wayland still not working ) to use Nvidia graphics with the "Primary GPU = true " config inside xorg.conf

1 Like

Actually one would want to follow the instructions here to use the nvidia GPU full time.


I tried to set to hybrid or integrated GPU (Intel) only, following the following tutorial: How to Install NVIDIA Driver & Switch Between Intel Graphics in Fedora 36 - FOSTips
However, the temperature kept high…

I didn’t think that using NVidia exclusively would solve the high temperature issue. But I tried it anyway and it didn’t work either.

I didn’t tried that way yet, but do you think it would solve the temperature issue?
I think integrated GPU (Intel) releases less heat than the discrete GPU (Nvidia), do you agree with that?

I guess that the reason for having high temperature is the Nvida card being always turned on, eventhough it is not beign used and I’m not being able to turn it off, despite all the things I’ve tried.

I just noticed that you have the above card.
I believe that card is only supported by the 470xx driver.
Please post the output of dnf list installed *nvidia* in </> preformatted text tags so we can see which driver you have installed.

I am not sure it will have any affect on the temps, but you said this is an old laptop and it is quite common for dust & lint to collect in the air passages inside a laptop and hinder cooling. I think the first thing you should consider is opening the case and thoroughly cleaning out all air flow passages for proper cooling.

My laptop is about 3 years old and runs 24x7. I have had to clean out the air flow passages twice in that time even though it sits on my desk with nothing to stir up dust & debris around it. Dust and lint happens!

Then, if you do not already have the 470xx drivers installed properly for the nvidia card we can approach that as a secondary goal.

dnf list installed *nvidia*
akmod-nvidia-470xx.x86_64 3:470.141.03-1.fc36
kmod-nvidia-470xx.x86_64 3:470.141.03-1.fc36
nvidia-gpu-firmware.noarch 20221012-141.fc36
nvidia-persistenced.x86_64 3:520.56.06-1.fc36
nvidia-settings-470xx.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx-cuda.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx-cuda-libs.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx-devel.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64 3:470.141.03-1.fc36
xorg-x11-drv-nvidia-470xx-libs.x86_64 3:470.141.03-1.fc36

Jeff, I’m claiming the temperature increase has to do with drivers or setups, because I recently updated from FC35 which still has the Bumblebee repo working and I had no temp issues. As I said in my first post, without any work load, it used to be between 50ºC and 60ºC, and rigth now it stays easily between 75ºC and 82ºC.

That shows you manually installed kmod-nvidia.
You should not manually install that because the akmod-nvidia package will automatically build the kmod-nvidia package and modules for your installed kernel. At one point it was necessary to install the kmod-nvidia package and not install the akmod-nvidia package but that is no longer the case.

I suggest that you remove that package. sudo dnf remove kmod-nvidia-470xx then upgrade the akmod-nvidia package to support functioning with the newer 6.0.5 kernel
sudo dnf upgrade akmod-nvidia-470xx --enablerepo=rpmfusion-nonfree-updates-testing --refresh

Your interpretation of the temperature issue may be correct but seems unlikely. I have never noted any temperature related issues from drivers, only from usage that puts a demand on the CPU or GPU. I have noted (as have many others) temperature issues caused by restriction of air flow in laptops. Air flow restrictions can cause 20 – 30 degree increases in temps in a very short time.

Jeff, I did what you recommend about the packages and I opened the computer to clean it. There were no considerable amount of dust, but I cleaned it anyway.

Since the begining I’m keeping the computer around 3cm above the table, in a way it can get enough air under it to not get even hotter.

However, the computer temp is still between 75ºC and 82ºC when there is no workload.

I just remembered that in F35 I used to get the same temp behavior if I stopped the Bumblebee service, and the temp would return to “normal” when I restarted the service.