Nvidia Kernel Module again missing after update

Did not know the expression red herring :-)) I hope, we will manage to track the issue

1 Like

red herring – something that is distracting or leads in the wrong direction.

Yes - I already found the translation - nice image…

Any idea how to go on?

did you install the other packages?

If you mean those packages - yes

That is not quite what I suggested.
sudo dnf install nvidia495 xorg-x11-drv-nvidia495
is not the same as
sudo dnf install nvidia*495* xorg-x11-drv-nvidia*495*
At best the first will only get 2 packages. The second will fill in all the packages I posted that were missing from your list. (looking closer I see the number appears to be italicized there so maybe you posted the *s in your quote and the system converted them to italics.)

You should also have the kernel-devel package installed since that is needed for akmods to build the nvidia driver from the akmod-nvidia package

Please post now the following. dnf list installed *nvidia* kernel-devel If that does not display a kmod-nvidia-5.14.17… package then the nvidia driver modules are not getting built.

dnf list installed *nvidia* kernel-devel
Installierte Pakete
akmod-nvidia.x86_64                        3:495.44-1.fc35  @rpmfusion-nonfree-nvidia-driver
kernel-devel.x86_64                        5.14.14-300.fc35 @updates            
kernel-devel.x86_64                        5.14.16-301.fc35 @updates            
kernel-devel.x86_64                        5.14.17-301.fc35 @updates            
kmod-nvidia-5.14.14-300.fc35.x86_64.x86_64 3:495.44-1.fc35  @@commandline       
kmod-nvidia-5.14.16-301.fc35.x86_64.x86_64 3:495.44-1.fc35  @@commandline       
kmod-nvidia-5.14.17-301.fc35.x86_64.x86_64 3:495.44-1.fc35  @@commandline       
nvidia-modprobe.x86_64                     3:495.44-1.fc35  @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                 3:495.44-1.fc35  @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                     3:495.44-1.fc35  @rpmfusion-nonfree-nvidia-driver
nvidia-xconfig.x86_64                      3:495.44-1.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                 3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64            3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64       3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-devel.x86_64           3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64         3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64            3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64           3:495.44-4.fc35  @rpmfusion-nonfree-nvidia-driver

Good mornng.I installed those packages properly :wink:

1 Like

In a quote or regular text the * does not appear since this forum sees a pair of *s as a code for the italics. To force it to show in a quote it needs to be entered as \*. Within a code (preformatted text) block it shows properly. I thus misread what you posted, and as you can see in your last post above it also does not show the * although the numbers are in italics.

Has anything so far made a difference?

If the nvidia drivers fail to load at this point the next step is to revert back to the nvidia 470 driver.

While it can be done with your repo config I would instead suggest adding the nvidia free and non-free repos as shown here.
Then do the following

sudo dnf remove *nvidia*
sudo dnf --disablerepo=rpmfusion-nonfree-nvidia-driver install akmod-nvidia*470.74* nvidia*470.74* xorg-x11-drv-nvidia*470.74* 

If you do not add the rpmfusion-free and rpmfusion-nonfree repos and disable the nvidia-nonfree-nvidia-driver repo the last install step will fail to provide three packages. nvidia-modprobe, nvidia-persistenced, & nvidia-xconfig for the 470 driver.

Unfortunatelly no

1 Like

That solution did work :wink: Thanks a lot!!
Do I have to change anything, that an update is not installing the newer drivers?

1 Like

Add the following line into /etc/dnf/dnf.conf
That will prevent the system from automatically replacing those drivers.

Thank you for your patience and persistence.
I was glad to assist and to know that the final fix was to revert back to the 470 driver.

Thank you for saving my ass :-)) - one last question wouldn’t it be beneficial for me in the future to receive updated drivers? Or is this no big deal?

And I am sorry that I also have to ask - how can I open /etc/dnf/dnf.conf again to inscribe the required text?

In a terminal you would type sudo nano /etc/dnf/dnf.conf and when your done type ctrl x then answer y to save the changes.


  1. The updated driver broke your system
  2. If the current driver does all that is needed is an update really beneficial? or necessary?