Nvidia + Fedora's Third Party Software Repos

Nvidia drivers are working just fine on my PCl. But out of curiosity, I attempted to determine if the Fedora Workstation steps via Software app would work, as this would be ideal for new users. However, I ran into a snag:

First, I enabled the repos via Software, and rebooted:

The repos are available and configured correctly, however, step #7 did not work as expected:

…open the software app. Click Add-ons> Hardware Drivers> NVIDIA Linux Graphics Driver> Install.

When opening Software, there is not a “Hardware Drivers” section available. The easy workaround which I found successful was just to run the following command:

rpm-ostree install kmod-nvidia xorg-x11-drv-nvidia

My question is why dont these steps work as documented? Is there an issue with Software app? Or is the issue elsewhere? Resolving this would be idea of new users.

I forgot to mention… I also had to run rpm-ostree kargs as part of the workaround. It would be idea if these workarounds were not needed so that it worked just like Fedora Workstation via Software app.