Nvidia drivers not working anymore after kernel 6.0.x update

power off, then when you power back on the first splash screen is the bios screen. As soon as it appears hold down the shift until the grub menu appears.

I performed all the steps without any problem - unfortunatelly, the 6.05* package was not loaded till now. The dnf list installed kmod-nvidia* command only shows 5.19 packages…

Also tried your suggestion - was unfortunatelly not working out. It says - no packages to install were found…

I guess you could just download and install the packages manually …

$ wget https://mirror.fcix.net/rpmfusion/nonfree/fedora/updates/testing/36/x86_64/a/akmod-nvidia-470xx-470.141.03-3.fc36.x86_64.rpm
$ wget https://mirror.fcix.net/rpmfusion/nonfree/fedora/updates/testing/36/x86_64/k/kmod-nvidia-470xx-470.141.03-3.fc36.x86_64.rpm
$ dnf update ./kmod-nvidia-470xx-470.141.03-3.fc36.x86_64.rpm ./akmod-nvidia-470xx-470.141.03-3.fc36.x86_64.rpm

If you went through all those steps, and the list you posted shows the akmod-nvidia-470xx.x86_64 3:470.141.03-1.fc36 package installed but it fails to build a kmod-nvidia-470xx-6.0.5 package then it seems an issue with

  1. the age of the driver
    and
  2. the new kernel.

I don’t think there is much more that can be done except possibly updating the currently installed driver with the one from the testing repo.
dnf upgrade akmod-nvidia-470xx --disablerepo=* --enablerepo=rpmfusion-nonfree-updates-testing
and try the version suggested by michael since it seems to work for him. Note that the version you have installed ends in -1 and the version michael is suggesting ends in -3. Probably specifically tweaked for the 6.0 kernel.

It says Pakage akmod-nvidia-470xx is available but not installed

Ah… you must have removed it.
replace update by install and try again.

It says the Pakage akmod-nvidia-470xx is not installed and cannot be actualized… Might the version change Jeff suggested help?

change ‘upgrade’ to ‘install’ and do not install the kmod-nvidia package. The system will build that for you from the akmod package which then may cause conflicts.

Sorry - mixed something up

What should I do then, if I should not install? Just click no and restart the system?

sudo dnf upgrade akmod-nvidia-470xx --disablerepo=rpmfusion* --enablerepo=rpmfusion-nonfree-updates-testing
should work if you did not remove the earlier installed nvidia packages. If you did remove them then
sudo dnf install akmod-nvidia-470xx --disablerepo=rpmfusion* --enablerepo=rpmfusion-nonfree-updates-testing
should work.

1 Like

Error:
Problem: conflicting requirements

  • nothing provides akmods required by akmod-nvidia-470xx-3:470.141.03-3.fc36.x86_64
  • nothing provides xorg-x11-drv-nvidia-470xx-kmodsrc >= 3:470.141.03 required by akmod-nvidia-470xx-3:470.141.03-3.fc36.x86_64
    (Try adding ‘–skip-broken’ to the command line to skip uninstallable packages)

don’t disable the repos that provide akmods etc

$ sudo dnf install akmod-nvidia-470xx --enablerepo=rpmfusion-nonfree-updates-testing

1 Like

I corrected my post above to only disable the potentially conflicting rpmfusion repos.

So - enabling the repos like Michael suggested might create potentially conflicting rpmfusion repos?

When 2 different repos that contain the same or similar packages are enabled there is always a potential for conflict. In the case of the rpmfusion repos and the nvidia drivers they are available in rpmfusion-nonfree, rpmfusion-nonfree-updates, rpmfusion-nonfree-nvidia-driver, and rpmfusion-nonfree-updates-testing. Dnf would have to determine which was most appropriate if it were able to select from all potential sources, while having the user select the repo of choice prevents dnf making a possibly inappropriate choice.

It is always better to avoid potential conflicts if possible, and the way I structured that command it prevents conflict since only the rpmfusion-nonfree-updates-testing repo would be available for use doing either the install or an upgrade. That command line also makes that one repo available and the others disabled only while that command is running. It does not affect normal use of dnf for other purposes.

Usually preference seems given to the repo from which a package was initially installed, so that is also a factor with trying to get updates from a new repo.

There shouldn’t be any conflicts. Install akmod-nvidia-470xx and the dependencies will be installed as needed.

$ dnf repoquery --requires akmod-nvidia-470xx --enablerepo=rpmfusion-nonfree-updates-testing
/bin/sh
/usr/bin/kmodtool
akmods
kmodtool
nvidia-470xx-kmod-common >= 3:470.103.01
nvidia-470xx-kmod-common >= 3:470.141.03
xorg-x11-drv-nvidia-470xx-kmodsrc >= 3:470.103.01
xorg-x11-drv-nvidia-470xx-kmodsrc >= 3:470.141.03

So is the problem just that the 470xx driver is only on the testing repos right now and hasn’t yet been pushed to the other repos? I haven’t had any problems until this kernel update but this one broke me. If so, I can wait. Do I need to do anything other than just keep doing dnf update?

Here are the repos I have enabled:

dnf repolist
repo id repo name
1password 1Password Stable Channel
anydesk AnyDesk Fedora - stable
code Visual Studio Code
fedora Fedora 36 - x86_64
fedora-cisco-openh264 Fedora 36 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 36 - x86_64
google-chrome google-chrome
phracek-PyCharm Copr repo for PyCharm owned by phracek
rpmfusion-free RPM Fusion for Fedora 36 - Free
rpmfusion-free-updates RPM Fusion for Fedora 36 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 36 - Nonfree
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam RPM Fusion for Fedora 36 - Nonfree - Steam
rpmfusion-nonfree-updates RPM Fusion for Fedora 36 - Nonfree - Updates
teamviewer TeamViewer - x86_64
updates Fedora 36 - x86_64 - Updates
updates-modular Fedora Modular 36 - x86_64 - Updates

yes, if you don’t want to update from the ‘rpmfusion-nonfree-updates-testing’ repo, just wait till it gets pushed to ‘rpmfusion-nonfree-updates’.
The cache has (I think) a 48hr timeout so if you actually want to check the state of the repo now, you need to expire the cache first.
$ sudo dnf clean expire-cache; sudo dnf update