NVidia drivers don't work with GTX 1060 6GB

I think I’ve tried all existing tutorials/solutions and still, my nvidia drivers don’t work.
Didn’t help: Fedora 34 GNOME 40 Nvidia driver install + cuda - #4 by tacalo
Didn’t help: https://www.fosslinux.com/44725/how-to-install-nvidia-drivers-on-fedora-workstation.htm


inxi -Fzx
$ inxi -Fzx
System:    Kernel: 5.11.18-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35.1-41.fc34 Desktop: GNOME 40.0 
           Distro: Fedora release 34 (Thirty Four) 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME H310M-E R2.0 v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 1002 date: 05/24/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard charge: 100% (should be ignored) status: Full 
CPU:       Info: Quad Core model: Intel Core i3-9100F bits: 64 type: MCP arch: Kaby Lake note: check rev: A cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
           Speed: 1943 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 1943 2: 800 3: 800 4: 800 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nouveau v: kernel bus-ID: 01:00.0 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1: 1920x1080~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: NV136 v: 4.3 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-5.1:4 
           Sound Server-1: ALSA v: k5.11.18-300.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.27 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A driver: r8169 
           v: kernel port: d000 bus-ID: 03:00.0 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 36.63 GiB (1.7%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS250G1B0C-00S6U0 size: 232.89 GiB temp: 34.9 C 
           ID-2: /dev/sda vendor: Seagate model: ST2000VX000-1ES164 size: 1.82 TiB 
Partition: ID-1: / size: 228.05 GiB used: 36.6 GiB (16.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 187.1 MiB used: 21.4 MiB (11.4%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 50.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 274 Uptime: 32m Memory: 31.3 GiB used: 2.94 GiB (9.4%) Init: systemd runlevel: 5 Compilers: gcc: 11.1.1 
           Packages: 1896 Shell: Bash v: 5.1.0 inxi: 3.3.03
$ modinfo -F version nvidia:

$ lspci -vnn | grep VGA
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) (prog-if 00 [VGA controller])

& nvidia-settings 
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system
System Info from settings

  1. I have low FPS in every game, when I used to have 1000 times more with Kubuntu.
  2. I can’t use CUDA/OptiX in blender

Both RPM Fusion and akmod-nvidia already installed

Did you see this?

In my case i tryed all methods too, but i made the last with clean install.

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda

Then just restart and be careful when you log back into the system. Previously in Fedora 33 after installing the nvidia drivers, the X11 session was preselected while in 34 it’s Wayland, so just make sure to select the X11 session.
After that you should hopefully be using the right drivers :crossed_fingers:

If you need cuda, this works for me:
sudo dnf config-manager --add-repo https://developer.download.nvidia.com/compute/cuda/repos/fedora33/x86_64/cuda-fedora33.repo
sudo dnf clean all
sudo dnf module disable nvidia-driver
sudo dnf -y install cuda

If your system take time to initialize (blackscreen) I have this too, the system take long time, but starts.

After this in the fedora loading screen after a while it said “NVidia kernel missing. Falling back to nouveau”, after what only one of my screens works and it has wrong resolution (I did everything except CUDA)

did it, nothing changed even after everything installed successfully. And now I can’t even change display settings. Should I uninstall everything back? (I did use sudo dnf remove nvidia* just so I can use my PC)

It actually worked, I just forgot to turn Secure Boot off. It was pretty obvious but I needed some time to realize. Thanks!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.