NVidia drivers and VirtualBox broken after update and GRUB2 config change, no GRUB2 menu

akmod-nvidia.x86_64                                3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
kernel.x86_64                                      6.4.7-200.fc38                   @updates                  
kernel.x86_64                                      6.4.8-200.fc38                   @updates                  
kernel.x86_64                                      6.4.9-200.fc38                   @updates                  
kernel-core.x86_64                                 6.4.7-200.fc38                   @updates                  
kernel-core.x86_64                                 6.4.8-200.fc38                   @updates                  
kernel-core.x86_64                                 6.4.9-200.fc38                   @updates                  
kernel-devel.x86_64                                6.4.7-200.fc38                   @updates                  
kernel-devel.x86_64                                6.4.8-200.fc38                   @updates                  
kernel-devel.x86_64                                6.4.9-200.fc38                   @updates                  
kernel-devel-matched.x86_64                        6.4.9-200.fc38                   @updates                  
kernel-headers.x86_64                              6.4.4-200.fc38                   @updates                  
kernel-modules.x86_64                              6.4.7-200.fc38                   @updates                  
kernel-modules.x86_64                              6.4.8-200.fc38                   @updates                  
kernel-modules.x86_64                              6.4.9-200.fc38                   @updates                  
kernel-modules-core.x86_64                         6.4.7-200.fc38                   @updates                  
kernel-modules-core.x86_64                         6.4.8-200.fc38                   @updates                  
kernel-modules-core.x86_64                         6.4.9-200.fc38                   @updates                  
kernel-modules-extra.x86_64                        6.4.7-200.fc38                   @updates                  
kernel-modules-extra.x86_64                        6.4.8-200.fc38                   @updates                  
kernel-modules-extra.x86_64                        6.4.9-200.fc38                   @updates                  
kernel-srpm-macros.noarch                          1.0-19.fc38                      @updates                  
nvidia-gpu-firmware.noarch                         20230804-152.fc38                @updates                  
nvidia-persistenced.x86_64                         3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
nvidia-settings.x86_64                             3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                         3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                    3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                 3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64               3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                 3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                      3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                    3:535.86.05-1.fc38               @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                   3:535.86.05-1.fc38               @rpmfusion-nonfree-updates

It would appear that something needed for the proper functioning of akmods has been broken with the kernel upgrade to 6.4.9.

At this point I would recommend that one do
sudo dnf remove akmods kernel-devel-*6.4.9* and allow it to remove all the dependencies as well.
Once that is done then do a reinstall of the nvidia drivers with dnf install akmod-nvidia which should also pull in all the needed dependencies at the same time.

If that is successful and it is able to enable the nvidia drivers then VirtualBox and v4l2loopback can both be reinstalled as well, but wait on those until the problem with nvidia is solved.

1 Like

That worked. TYJ! :smiley:

Will now attempt reinstalling virtualbox and v4l2loopback…

Edit: They are reinstalled, and the graphics still work. Thank you!

Glad to assist and that you were successful. :sunglasses:

Irritating when something at that low a level seems to get corrupted :thinking:

It then becomes necessary to use a bigger hammer. :hammer_and_pick: