NVIDA 340* Fedora 31

Brand New install of Fedora 31, Did dnf update and then followed instructions from

![/!|15x15](https://rpmfusion.org/moin_static1910/rpmfusion/img/alert.png "/!") Workaround for keeping 340xx driver on newer f31+.

sudo dnf copr enable kwizart/kernel-longterm-4.19  
sido dnf install akmods gcc kernel-longterm kernel-longterm-devel 
sudo dnf install xorg-x11-drv-nvidia-340xx akmod-nvidia-340xx --releasever=30

The first two dnf intructions worked well but the 3rd fails with

Is this ok [y/N]: y
Key imported successfully
warning: /var/cache/dnf/rpmfusion-nonfree-updates-5df6142a4a60155a/packages/akmod-nvidia-340xx-340.107-8.fc30.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID 1d14a795: NOKEY
RPM Fusion for Fedora 30 - Nonfree - Updates                                           0.0  B/s |   0  B     00:00    
Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-30 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-30]
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

I have run dnf update again but returns with no change

Help always gratefully recieved
Thanks in advance

Hi @orriginal

Try one of the this 2 options, I hope it can help you.

A) Adding manually the key

1-Download from rpm fusion the key that is being demanded so called : RPM-GPG-KEY-rpmfusion-nonfree-fedora-30

Link to download

Download the file called “RPM-GPG-KEY-rpmfusion-nonfree-fedora-30”

2- Copy the file to the path of the keys that was indicated : /etc/pki/rpm-gpg/

sudo cp /<path of folder where you did download file>/RPM-GPG-KEY-rpmfusion-nonfree-fedora-30 /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-30

Now the key get added where it was demanded.

3-Try install the package again.

sudo dnf install xorg-x11-drv-nvidia-340xx akmod-nvidia-340xx --releasever=30

B) In the other hand you can try install without do a check of keys with the option --nogpgcheck :

sudo dnf --nogpgcheck install xorg-x11-drv-nvidia-340xx akmod-nvidia-340xx --releasever=30


1 Like

THANK YOU - I followed your excellent instruction and it all appears to have worked after I followed the first set od instructions.

I did notice, during installation / Downgrading, some errors which I have listed below for your information - But as I said, it appears to have worked fine and the NVidia sever is not shown and works

the listed errors were, in order of appearance
1 )

ls: cannot access '/boot/vmlinuz-.fc31.x86_64': No such file or directory

2 )

 Running scriptlet: abrt-addon-ccpp-2.13.0-1.fc31.x86_64                                              90/151
Failed to try-restart abrt-ccpp.service: Unit abrt-ccpp.service not found.

3 )

Warning: The unit file, source configuration file or drop-ins of dnf-makecache.timer changed on disk. Run 'systemctl daemon-reload' to reload units.

SADLY, having said it all worked, when I did a Hard reboot…Nothing worked and I could not even get tot he log in screen…and not even the RESCUE option on the boot option screen worked…SO… Here I am , booted up from the USB, about to install again, for the 3rd time…
Hopefully it’ll work this time

This error is really serious (the others is about ABRT you can try reload it run the command indicate sudo systemctl daemon-reload) because it looks like your kernel get damage in someway than i don’t know. If you do see this error after you did reinstall again before you reboot try reinstall the kernel/s

sudo dnf reinstall kernel*

Try reinstall kernel before you do reboot if you can not repair the image of your kernel it will happen again. Maybe someone can help a bit more about how recover the kernel my first idea is just reinstall it before a reboot.

Edit: It also looks like that the kernel LTS than you did install present problems actually


So you would wait until his build be right.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.