Not booting after Fedora 37 upgrade

I followed Software installer in upgrading from Fedora 36 to Fedora 37. After install and reboot I end up in GRUB shell.

I try to boot again using this.

The result is the same for all available kernel versions including rescue.

Error message in dracut shell:

[FAILED] Failed to start initrd-switch-root.service

:/root# systemctl status initrd-switch-root.service

Failed to switch root: Specified switch root path ‘/sysroot’ does not seem to be an OS tree. os-release file is missing.

In journalctl maybe interesting errors:

EFI loader partition unknown, exiting.
(The boot loader did not set EFI variable LoaderDevicePartUUID.)

How to complete boot?

Resetting the PRAM solved the problem. Explanations welcomed.

Only clue I see is there with the comment about OS tree. Are you using the Workstation install or perhaps running silverblue or kinoite?

I don’t know what is the Worstation install. I use Fedora 37 as installed automatically by Fedora 36. Resetting the PRAM solved the problem on my main installation but I still have the problem on a backup installation. What is this /sysroot?