Not able to setup fedora

Hi, its my first time here! Im having trouble using the fedora installer to install fedora on my device. I am able to click keyboard that is under localization, but am not able to hit time & date, or Installation Destination. Could you guys help?

What do you mean exactly? You cant click?

Normally a map opens, you click where you live and its set automatically

im unable to click the installation destination

What device are you attempting to install on? laptop? desktop? sbc? tablet?

Brand and model as well as architecture may be helpful.

That looks to me like it is not properly communicating with the hardware since it still shows prompts under the links that it is trying to obtain the info before it can enable those links.
Restoring hardware time... and Probing storage...

1 Like

laptop, heres my neofetch : (yes i am switching from arch to fedora)

I have installed fedora before, it worked, but i changed to arch, and i want to change back again.

Ok, so it seems an x86_64 architecture.

Note that using the image and not posting text has clipped a major portion of the output on the right side.

Mine shows

$ neofetch
         .';:cccccccccccc:;,.            ----------------------- 
      .;cccccccccccccccccccccc;.         OS: Fedora Linux 39 (Workstation Edition) x86_64 
    .:cccccccccccccccccccccccccc:.       Host: B550M Pro4 
  .;ccccccccccccc;.:dddl:.;ccccccc;.     Kernel: 6.5.11-300.fc39.x86_64 
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.    Uptime: 4 days, 3 hours, 34 mins 
.:ccccccccccccc;KMMc;cc;xMMc:ccccccc:.   Packages: 3605 (rpm), 15 (flatpak) 
,cccccccccccccc;MMM.;cc;;WW::cccccccc,   Shell: bash 5.2.21 
:cccccccccccccc;MMM.;cccccccccccccccc:   Resolution: 1920x1080, 1920x1080 
:ccccccc;oxOOOo;MMM0OOk.;cccccccccccc:   DE: GNOME 45.1 
cccccc:0MMKxdd:;MMMkddc.;cccccccccccc;   WM: Mutter 
ccccc:XM0';cccc;MMM.;cccccccccccccccc'   WM Theme: Adwaita 
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;    Theme: Adwaita [GTK2/3] 
ccccc;0MNc.ccc.xMMd:ccccccccccccccc;     Icons: Adwaita [GTK2/3] 
cccccc;dNMWXXXWM0::cccccccccccccc:,      Terminal: gnome-terminal 
cccccccc;.:odl:.;cccccccccccccc:,.       CPU: AMD Ryzen 7 5700X (16) @ 3.400GHz 
:cccccccccccccccccccccccccccc:'.         GPU: NVIDIA Geforce RTX 3050 
.:cccccccccccccccccccccc:;,..            Memory: 9661MiB / 32004MiB 

What are you booting from? a usb device that contains the fedora 39 live image? or something else?
What file systems are already on the drive you are installing to?
Is free space available for the install or will you need to free up space or wipe the drive and start new?

The fact it cannot read the hardware time nor the drive config seems troubling unless you have the bios locked down with a password or other config that does not allow booting from usb to read the hardware. I know that some hardware has bios settings that do not allow certain actions from a usb device for security purposes. If you have the bios set that way then it may be necessary to relax those restrictions before a new OS may be installed.

usb device that contains the fedora 39 live image
idk about the rest :frowning:

How would i be able to make fedora see the hard drive?

You obviously were able to boot to the live fedora system before you selected to install.

This is where you would check devices.
Open a terminal and use the commands su followed by fdisk -l to actually see the drives, which should show every drive physically connected and the partitioning of each.

1 Like

In BIOS, is your SATA controller set to “AHCI”?

I do not know. How would i check, in the F10 setup?

yes i was. I should open fedora live terminal? ok

/dev/nvme0n1 is my main drive, i found out

It works, but it says , "error wiping old signatures from /dev/nvme0n1p1: Errno 5] input/output error:wipefs

Fixed it by messing around with bios.