Noob help, no wifi Fedora 36 LXQT

-------WiFi does not appear at all in Fedora. No problems with Ubuntu/Debian installs or Windows installs. This may be the wrong place to post this, but it seems this is the only place it wanted me to post, sorry if it’s wrong, just needed a little help from anyone more experienced with Fedora. It does seem to be a common issue, but none of the solutions have worked for me yet.

rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
nmcli con show
NAME                UUID                                  T>
Wired connection 1  f754b5ed-3beb-3c11-b8a6-521293b2fb2c  e>
Wi-Fi connection 1  7ab4ba5d-66f9-4410-9d8b-f836df30763d  w>
01:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43228 802.11a/b/g/n
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

Only wired connection shows. Wired connection works fine, no problems there. Installed rpmfusion free and nonfree and a couple packages I read about but still no WiFi yet. There is one Broadcom package in dnfdragora that appears in search results but It can never seem to be installed. No errors, just always appears in the “Not Installed” catagory.

-----Perhaps no WiFi driver is installed for my laptop by default. I need to know the exact driver to install and where to find it.

Not yet known.

Related Issues

Bugzilla report: #NNNN

-----------The only workaround is to actually plug the laptop in to the router with a physical cable.

None yet.

1 Like

This is correct. You need to install the proprietary driver for your Broadcomm hardware from RPM Fusion:

followed by

sudo dnf install broadcom-wl

Info on the package:

$ sudo dnf info broadcom-wl
Last metadata expiration check: 0:02:57 ago on Fri 09 Sep 2022 10:10:12 BST.
Available Packages
Name         : broadcom-wl
Version      :
Release      : 19.fc36
Architecture : noarch
Size         : 24 k
Source       : broadcom-wl-
Repository   : rpmfusion-nonfree-updates
Summary      : Common files for Broadcom 802.11 STA driver
URL          :
License      : Redistributable, no modification permitted
Description  : This package contains the license, README.txt and configuration
             : files for the Broadcom 802.11 Linux STA Driver for WiFi, a Linux
             : device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-,
             : BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-,
             : BCM43228-, BCM4331-, BCM4360 and -BCM4352- based hardware.

Install the 50+ packages containing required build tools, kernel-devel-matched:
dnf install kernel-devel-matched akmod-wl
Automates build/pkg/install of wl kernel module when kernel is updated.

Sadly tried both of these things, along with some more similar things I found, but still no WiFi. I really appreciate the help though. It does seem that this is a common problem that many people have, and sometimes the steps above work, but sometimes for other people they don’t. Not sure why… Of course I fall into the category of people whose WiFi still doesn’t work. Is there any hope left, or is it just a thing and I’ll either have to live with it or install another distro for now?
Another post suggested posting the output of iwconfig, however that command is not found. There are still no WIFi connections listed, and no WiFi category. I am puzzled here. Thanks again for all your help, and for taking your time to read this.

1 Like

Maybe one or more if these packages are needed

[root@newbox ~]# dnf list b43\*
Last metadata expiration check: 4:11:30 ago on Wed 14 Sep 2022 07:21:30 CEST.
Available Packages
b43-firmware.noarch           rpmfusion-nonfree-tainted
b43-fwcutter.x86_64          019-21.fc36                   fedora                   
b43-openfwwf.noarch          5.2-28.fc36                   fedora                   
b43-tools.x86_64             019-13.fc36                   fedora                   
[root@newbox ~]# 

That’s odd. The akmods take some time to build after the dnf command finishes (the RPM Fusion Nvidia page notes: “Please remember to wait after the RPM transaction ends, until the kmod get built. This can take up to 5 minutes on some systems.”

Could you please post the output of sudo fpaste --sysinfo --printonly please? I guess we first need to see if the device is recognised. If it is, we need to see why it won’t work. It’s also worth checking if your computer has a hardware switch for wifi. Sometimes this is automatically turned off and needs toggling.

Thank you very much Villy Kruse, that may be a solution. I haven’t seen that one before. I really couldn’t try it though because dnf can’t find any b43 packaged, either in terminal or gui. I did find a few pacages I could download directly from an Arch Linux repository I think it was, but would really like to get them directly from a Fedora repository if possible. Is that possible? How did you get them, did you just google and download directly, or is there another repository I need? I already have the rpm fusion enabled… Thanks again for your help!!!

Thank you so much for your assistance and help Ankur Sinha, I really appreciate any suggestions you can offer. First, WiFi IS working everywhere else on both Windows and Debian, so no problems there. As to the print out, it’s LONG, sorry about that! Anyway here it is:

I’ll try to read through that as well & see if anything jumps out at me. Just curious, is this a common thing with every release of Fedora? Thanks so much again for your help!

Okay, a new problem has presented itself. I don’t know how to get the information to you. First it kept giving me errors about how I’m only allowed 2 links as a new user. Didn’t know I even used one… Anyway, so I tried to save it to a text file, didn’t work. Tried compressing that text file, still didn’t work. It seems I’m only allowed to upload pictures. Thought I could fool it by renaming it from a zip to jpg and just telling you to change the extention but that didn’t work either, probably because it wants to actually display the picture. So… how can I get you the info you need? Sorry to bother you again and be a pain, I really do appreciate your help!

Don’t worry about those b43 packages for now. The important step is to install broadcom-wl which will pull in everything that is needed to build the kernel module, and also build it.

You alread have the instruction to do that. After that there will be additional instruction, but you first need to complete this instruction.

1 Like

Thank you again for your help! Broadcom-wl has already been installed. That was my main problem, that I installed broadcom-wl but still didn’t seem to get anywhere. What are the next instructions?
PS. Here is my output from trying to install it again:

Last metadata expiration check: 1:04:04 ago on Tue 20 Sep 2022 12:05:08 AM EDT.
Package broadcom-wl- is already installed.
Dependencies resolved.
Nothing to do.

Hey howdy!

I have a Broadcom wifi card and what helped me fix it was going here to the rpmfusion site: Configuration - RPM Fusion

And installing the following repos:

sudo dnf install rpmfusion-free-release-tainted
sudo dnf install rpmfusion-nonfree-release-tainted

Then I installed the b43-firmware and akmod-wl packages and that allowed my Broadcom card to function.

Hope it works for you!

1 Like

Check if you have a signing key for the akmod modules

sudo file /etc/pki/akmods/certs/public_key.der

If you do, you should enroll that key in the MOK as described in the file /usr/share/doc/akmods/README.secureboot.

If you don’t, the same file have instructions on how to generate that key. Then run

sudo dnf remove kmod-wl\*
sudo dnf reinstall akmod-wl

Then find the generated wl module

find /usr/lib/modules/$(uname -r)/extra -type f

Then run modinfo with the name of the module as argument. It will show if the module have a signature or not.

1 Like

Had a few other issues, the last one with dns, which are now resolved. Not sure how they happened… Anyway, upon checking, I get EFI variables are not supported on this system. Probably because my system is BIOS. The first command seems to confirm there is a key though. I cannot browse there with the file manager though, only as far as certs, then I have a permission error. AmI still missing something, or do the instructions change because I am using a BIOS system?

The second set of instructions were done and successful, the uninstall and reinstall, but the find string just did nothing. No output, no error, no nothing, just displayed my command prompt again. Since the reinstall akmod command reported success, I am assuming that maybe this also has something to do with BIOS/UEFi setup, but I could be, and probably am, wrong.

1 Like

Thank you very much!!! Sorry it’s taking me a while, I have my main Linux distro which works and where I do most of my work, when I don’t need Windows. Anyway, I did run the commands after overcomming some DNS issues, and they finally worked and I installed b43-firmware, finally! Still no WiFi, but that maychange once I reboot. Keeping my fingers crossed!!

1 Like

Sadly still no WiFI even after a reboot. Bummer. Why is it so complicated to set up WiFi in Fedora? Anyway, thank you very much for your help. I really had my hopes up there with new information (the Tainted part) and finally being able to install the b43 stuff but alas, still not showing any WiFi networks…

1 Like

It’s a mixture of closed source drivers (if they were open source and in the kernel like all the other hardware out there, we wouldn’t have to do all this extra stuff) and/or secureboot (also a major issue because if this is enabled, one cannot load extra kernel modules and so on).

So, it’s unfortunately not an issue that Linux/Fedora created, but one that we need to deal with as users.


  • was the kernel module built?
  • was it loaded, if built?
  • what’s the output of sudo lsmod?
1 Like

B43 may be for newer hardware only; is your machine older or newer? (My Broadcom card is from 2016+)

1 Like

Please don’t laugh, but mine is 2014 i believe. A Lenovo X140e.

Sorry, that was the output of lsmod, I wasn’t sure if it would let me post it. I am using Fedora 36, the latest edition and updated. Hopefully you’ll be able to tell something… And will this be a procedure everytime I upgrade Fedora? Or once we get it figured out I’ll be set?

Module                  Size  Used by
rfcomm                 94208  4
snd_seq_dummy          16384  0
snd_hrtimer            16384  1
xt_comment             16384  0
nft_compat             20480  0
nft_fib_inet           16384  1
nft_fib_ipv4           16384  1 nft_fib_inet
nft_fib_ipv6           16384  1 nft_fib_inet
nft_fib                16384  3 nft_fib_ipv6,nft_fib_ipv4,nft_fib_inet
nft_reject_inet        16384  6
nf_reject_ipv4         16384  1 nft_reject_inet
nf_reject_ipv6         20480  1 nft_reject_inet
nft_reject             16384  1 nft_reject_inet
nft_ct                 24576  15
nft_chain_nat          16384  2
nf_nat                 57344  1 nft_chain_nat
nf_conntrack          163840  2 nf_nat,nft_ct
nf_defrag_ipv6         24576  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
ip_set                 57344  0
nf_tables             274432  229 nft_ct,nft_compat,nft_reject_inet,nft_fib_ipv6,nft_fib_ipv4,nft_chain_nat,nft_reject,nft_fib,nft_fib_inet
nfnetlink              20480  4 nft_compat,nf_tables,ip_set
qrtr                   49152  4
bnep                   28672  2
binfmt_misc            28672  1
squashfs               73728  12
loop                   32768  24
btusb                  65536  0
btrtl                  28672  1 btusb
btbcm                  20480  1 btusb
btintel                49152  1 btusb
btmtk                  16384  1 btusb
snd_ctl_led            24576  0
bluetooth             802816  36 btrtl,btmtk,btintel,btbcm,bnep,btusb,rfcomm
snd_hda_codec_realtek   163840  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     73728  1
amd_freq_sensitivity    16384  0
edac_mce_amd           40960  0
uvcvideo              126976  0
snd_hda_intel          57344  4
kvm_amd               151552  0
videobuf2_vmalloc      20480  1 uvcvideo
ccp                   114688  1 kvm_amd
videobuf2_memops       20480  1 videobuf2_vmalloc
snd_intel_dspcfg       32768  1 snd_hda_intel
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
videobuf2_v4l2         36864  1 uvcvideo
snd_hda_codec         172032  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
think_lmi              32768  0
videobuf2_common       69632  4 videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,videobuf2_memops
kvm                  1064960  1 kvm_amd
firmware_attributes_class    16384  1 think_lmi
videodev              278528  3 videobuf2_v4l2,uvcvideo,videobuf2_common
ecdh_generic           16384  2 bluetooth
snd_hda_core          110592  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
pcspkr                 16384  0
snd_seq                90112  7 snd_seq_dummy
irqbypass              16384  1 kvm
mc                     69632  4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
snd_seq_device         16384  1 snd_seq
wmi_bmof               16384  0
snd_pcm               151552  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
joydev                 28672  0
k10temp                16384  0
fam15h_power           16384  0
i2c_piix4              28672  0
snd_timer              49152  3 snd_seq,snd_hrtimer,snd_pcm
acpi_cpufreq           28672  0
zram                   28672  2
amdgpu               8015872  0
iommu_v2               24576  1 amdgpu
gpu_sched              49152  1 amdgpu
rtsx_pci_sdmmc         32768  0
mmc_core              200704  1 rtsx_pci_sdmmc
crct10dif_pclmul       16384  1
crc32_pclmul           16384  0
crc32c_intel           24576  3
ghash_clmulni_intel    16384  0
radeon               1667072  16
serio_raw              20480  0
sp5100_tco             20480  0
thinkpad_acpi         131072  0
rtsx_pci              110592  1 rtsx_pci_sdmmc
ledtrig_audio          16384  3 snd_ctl_led,snd_hda_codec_generic,thinkpad_acpi
r8169                  98304  0
snd                   114688  22 snd_ctl_led,snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,thinkpad_acpi,snd_pcm
drm_ttm_helper         16384  2 amdgpu,radeon
soundcore              16384  2 snd_ctl_led,snd
ttm                    81920  3 amdgpu,radeon,drm_ttm_helper
platform_profile       16384  1 thinkpad_acpi
wmi                    32768  2 wmi_bmof,think_lmi
rfkill                 36864  4 bluetooth,thinkpad_acpi
video                  57344  1 thinkpad_acpi
sunrpc                655360  1
be2iscsi              131072  0
bnx2i                  57344  0
cnic                   73728  1 bnx2i
uio                    24576  1 cnic
cxgb4i                 53248  0
cxgb4                 544768  1 cxgb4i
tls                   114688  1 cxgb4
cxgb3i                 40960  0
cxgb3                 184320  1 cxgb3i
mdio                   16384  1 cxgb3
libcxgbi               77824  2 cxgb4i,cxgb3i
libcxgb                28672  2 libcxgbi,cxgb3i
qla4xxx               315392  0
iscsi_boot_sysfs       20480  2 be2iscsi,qla4xxx
iscsi_tcp              28672  0
libiscsi_tcp           36864  4 libcxgbi,iscsi_tcp,cxgb4i,cxgb3i
libiscsi               73728  8 be2iscsi,libiscsi_tcp,bnx2i,libcxgbi,iscsi_tcp,qla4xxx,cxgb4i,cxgb3i
scsi_transport_iscsi   143360  7 be2iscsi,libiscsi_tcp,bnx2i,libcxgbi,iscsi_tcp,qla4xxx,libiscsi
fuse                  172032  3
ipmi_devintf           20480  0
ipmi_msghandler       122880  1 ipmi_devintf
1 Like