No WiFi after first boot after F35 to F36 upgrade

I upgraded from Fedora 35 to 36 and has no WiFi connection suddenly…

The WiFi was listed under “Saved networks” (I double-checked) and IIRC it also tried to auto-connected (i.e. it could also find the network, it was shown in the list), however, it showed the password prompt. Despite being “saved”. (It was working properly in Fedora 35.)

First I dismissed the popup and clicked again to connect, it showed it again. Then I checked the things I’ve just said and then I just tried entering the password (after finding it *somewhere* obviously… :upside_down_face:). Until now, this works without problems now…

As such, if this is checked/confirmed/debugged more properly, it could be a case for #common-issues / Proposed Common Issues .


What can I do to debug this more or so in case it happens again (e.g. with a different wifi network that is also “saved”.)

Maybe it is something one could have a look at? I.e. it should not cause more harm…
Because having no network is really a bummer to debug things, you cannot even easily find this information here… :wink:
Yet alone copy/transfer a wifi password there – and that assumes you know/have it somewhere…


(Now somewhat more updated)

rpm-ostree status -v
State: idle
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: last run 5h 37min ago
● fedora:fedora/36/x86_64/silverblue
                   Version: 36.20220512.1 (2022-05-12T20:00:12Z)
                BaseCommit: 298486a9757785902e07482e5a71008e521e9d1c92d7a98e6bc25ac53c966f9f
                            ├─ repo-0 (2022-05-04T21:16:11Z)
                            ├─ repo-1 (2022-05-12T19:35:04Z)
                            └─ repo-2 (2022-05-12T19:36:45Z)
                    Commit: 823c7b3d3d4af36293ea6d2a3c7635e8bacbdb0692b6296f7546446b5fd78a13
                            ├─ fedora-modular (2022-05-04T21:12:01Z)
                            ├─ fedora (2022-05-04T21:16:11Z)
                            ├─ rpmfusion-free (2022-05-04T04:48:11Z)
                            ├─ fedora-cisco-openh264 (2022-04-07T16:52:38Z)
                            ├─ updates (2022-05-13T01:50:57Z)
                            ├─ rpmfusion-free-updates (2022-05-09T05:15:49Z)
                            ├─ updates-modular (2022-05-08T01:14:17Z)
                            └─ updates-archive (2022-05-12T20:41:38Z)
                    Staged: no
                 StateRoot: fedora
              GPGSignature: 1 signature
                            Signature made Do 12 Mai 2022 22:00:44 CEST using RSA key ID 999F7CBF38AB71F4
                            Good signature from "Fedora <>"
       RemovedBasePackages: pipewire-pulseaudio 0.3.51-1.fc36 wireplumber 0.4.9-1.fc36
           LayeredPackages: adb compat-ffmpeg28 dconf-editor firewall-config git git-credential-libsecret git-subtree
                            gnome-tweaks gstreamer1-plugin-openh264 gtkhash-nautilus heimdall htop httpie keepassxc kid3
                            lshw mozilla-openh264 nautilus-image-converter nextcloud-client nextcloud-client-nautilus
                            nvme-cli openssl pipewire-media-session podman-compose rpmfusion-free-release simple-scan
                            smartmontools sushi tldr zsh