No WiFi adapter found issue_ HP probook 440G2_fedora 38 workstation edition

installed fedora via usb. i tried to install the rpm fusion again but it just says nothing to do and complete!
I am fairly new to linux and terminal. so please help me with this issue. fyi i am able to connect to the internet in via ethernet

Welcome to Ask.Fedora.
Let’s first find out what Wi-Fi chipset your machine has. From a terminal you run the following command and look for the name of the Wireless Network adapter


thanks. Network controller: Broadcom Inc. and subsidiaries BCM43228 802.11a/b/g/n

Looks like: would be pertinent to you then.

1 Like

Having ethernet will be helpful. You are about to find that keeping a linux system in good working order often requires use of a terminal (e.g., command line). There are many good (and even more bad) online references and tutorials for the linux command line. Some configuration options are not available in the GUI, and it is difficult to explain GUI manipulations in a text-oriented forum.

I used to work with PhD level scientists who needed to run specialized command-line software, and used Linux Command to introduce the command line. Try to get through chapter 1, and then you can refer to other material as needed. Paticularly if English is not your native language, you should seek out a reliable reference manual in a language you prefer. It is also useful to make contact with other nearby linux users – sometimes it is much easier for someone with eyes on the system to resolve issues.

Back to your issue: Linux Hardware Database shows for probes for this chipset with Fedora 38 on Dell hardware: 3 failed, 1 detected, none working. This chipset should be supported by the nonfree wl driver from Have you enabled the rpmfusion non-free repositories? If not, see RPM Fusion Configuration.

rpmfusion us enabled but still the same issue

as per the instructions i tried to do the sudo dnf install kmod-wl but received the following response,
No match for argument: kmod-wl
Error: Unable to find a match: kmod-wl

You need rpmfusion-nonfree:

$ dnf info kmod-wl
Available Packages
Name         : kmod-wl
Version      :
Release      : 46.fc38
Architecture : x86_64
Size         : 9.1 k
Source       : wl-kmod-
Repository   : rpmfusion-nonfree
Packager     : RPM Fusion
Buildtime    : Tue 03 Jan 2023 05:01:05 AM
Summary      : Metapackage which tracks in wl kernel module for newest kernel
URL          :
License      : Redistributable, no modification permitted
Description  : This is a meta-package without payload which sole purpose is to require the
             : wl kernel module(s) for the newest kernel,
             : to make sure you get it together with a new kernel.

As mentioned above, but I think you probably need instead the broadcom-wl package which will automatically pull in the akmod-wl package.

The instructions on the link above are for fedora 30 and the newer install method using the broadcom-wl package will locally build the kmod-wl package specific to your installed kernel, then keep it up to date with changes in kernel or drivers.

1 Like

kmod-wl metapackage pulls in akmod-wl, etc.

% dnf repoquery --requires --resolve kmod-wl
Fedora 38 - x86_64 - Updates                                                             96 kB/s |  24 kB     00:00
Fedora Modular 38 - x86_64 - Updates                                                    121 kB/s |  23 kB     00:00
% dnf repoquery --requires --resolve akmod-wl
Last metadata expiration check: 0:00:11 ago on Thu 07 Sep 2023 06:40:30 PM.