No video in GNOME Web (mostly)

On Fedora 35 here. In GNOME Web, most videos never load. Youtube, Vimeo, etc. Youtube ads often show, but the actual video after the ad almost never shows. For some reason, “Song for the future generations” by the B52’s does work, which is nice. But I’d rather see other videos too. :slight_smile: Am I missing some codec or something else? Maybe related to PipeWire or something? In Firefox, everything works. Sorry for the vague question, but I’m at a total loss trying to troubleshoot the issue.

Update: To make things more confusing, YouTube Music works, and it shows videos too.

1 Like

Hi there! Just to say that you’re not alone, just tested Gnome web and same, not even the B52’s song for a future generation plays … Firefox and everything else working fine.

edit : I tried from another computer and it works fine on this other one. The first one on which it does not work is a thinkpad with AMD CPU && GPU, the other an old macbook with Intel CPU && GPU, if that can help.

1 Like

could be you miss ffmpeg (sudo dnf install ffmpeg)

1 Like

GNOME Web uses GStreamer framework, so you need to enable RPMFusion repositories and install additional codecs:

1 Like


RPM fuson free and non free installed, all extra codecs installed except the eSpeak one :

“GStreamer Multimedia Codecs - Extra”
“GStreamer Multimedia Codecs”
“GStreamer Multimedia Codecs - Base”
“GStreamer Multimedia Codecs - H.264”
“GStreamer Multimedia Codecs - libav”
“GStreamer Multimedia Codecs - License Issues”
“GStreamer Multimedia Codecs - Non Free”

Still persists. Tried to reinstall gnome web, still persists. Tried the flatpak version instead of the RPM one, same.

Hi @armandraynal I did post your question at the Gnome People. Web epiphany does not show video - Applications - GNOME Discourse
You could watch the issue by enabling Watching on that page
(Hope you don’t mind using your text… :innocent:


The Gnome People (Web epiphany does not show video - #2 by mcatanzaro - Applications - GNOME Discourse) say this:
It’s expected to be broken before your first system update for legal reasons. After your first system update, it ought to work. Please check: rpm -qi gstreamer1-openh264 . That package is required. Try installing it if it’s missing, although it really shouldn’t be missing.

Also please check: rpm -qi gstreamer1-vaapi . If that’s installed – it really shouldn’t be, unless you installed it manually – then try uninstalling it, since it often breaks video playback on particular hardware.

Another thing to check: rpm -qi gstreamer1-libav . This package isn’t available from Fedora for legal reasons, but it’s worth checking for because if you installed it from elsewhere then you’re going to have a completely different (should be better) media pipeline than the normal one.

1 Like

Not at all! Thanks a lot for your help!

gstreamer1-openh264 is not found by a dnf search, I guess it’s the one called gstreamer1-plugin-openh264

It was already installed. The VAAPI one was not installed.

gstreamer1-libav is in fact available on fedora, I guess probably thanks to the RPM fusion repos, so I tried installing it just to see if it made a difference, but nope. So I just uninstalled it, updated (had already updated since upgrading to fedora 35 several times before of course), then restarted the computer, and somehow, it now works …

Well, it plays the youtube videos fine now, but now going up and down on the page is extremely stuttery, it’s basically unusable … Not to mention that it is very noticeably slow to load pages, anything from 10 to 20 seconds …

edit : also tried disabling the adblock function, same.

I have experienced with bad performance browser but on Chrome hardware acceleration setting.

Maybe you could try to change the setting on Firefox mentioned here: Performance Setting

Firefox works fine, it’s only epiphany that has this issue.

After more testing it seems it’s the gstreamer1-libav package that makes it work, but not on all videos, and with the aforementioned performance issue. Removing this package makes it not have performance issue, pages load fast it seems, but no youtube videos at all will play.

edit : in fact gstreamer1-libav installed or not, it plays videos for some time, then stops working as soon as I open a new tab with anything else … then no longer works until I reboot again …

edit 2 : testing more browsers, midori doesn’t play videos either, chromium either and it even breaks youtube on firefox and audio system wide, replacing the speaker by a dummy output logging out and in again, requiring a restart to get audio back …

GNU Icecat works once youtube it whitelisted in the JS blocking add on, but funnily it replaces youtube’s player’s interface on videos by it’s own default html5 interface, which let you chose between mp4 and webm for instance, quite interesting …

edit 3 : just tested Opera, it also “breaks the media pipeline” system-wide like chrome it seems, youtube stops working on firefox and GNU Icecat from the moment I open youtube on Opera, and after logging out and in again which solves that youtube playing issue for Firefox and Icecat, all audio is not working anymore, microphone is not detected, nor speakers, with only a dummy output available, requiring a reboot to get audio again.

I’m pratically on the same boat as you, except I can’t see youtube videos at all.

This is the link to the GNOME diskussion about this issue.

Seems to be a bug.