No sound through speakers Lenovo Ideapad/Yoga S740-15

Hello all, I have been trying to get sound on through my speakers on my dual boot setup with fedora 33 x64 without succes. There doesn’t seem to be a solution online for this issue and some other newer laptops with the same type of audio card configuration have got the same issue, so maybe this post will get some answer.

Here is the alsa-info script output, it includes the dmesg for the audio and all appropriate drivers.


So far I have tried adding commands to the boot command line, remapping the pins, but all resulted in still no sound. The headphone jack stops working at random as well but I think that issue is related to the speaker problem.

Is anyone able to help me troubleshoot this a bit further?
Thanks in advance.

1 Like

Hi Tijs,

have you tried pavucontrol? Sometimes that helps people to get some sound.

Yes, I have tried that but it sadly doesn’t work, the speakers show up in pavucontrol, the sound bar moves indicating there is supposed to be sound, but there is none. Sound through an HDMI connection does work however.

I have just the same problem. Under pavucontrol the bar moves, but there is no sound. I have dedicated a lot of time and I have not been abloe to find a solution. Have you found a solution to this problem?. I appreciatte some help

USB headset works fine


Nope I haven’t been able to find a solution to this problem yet. There are bug reports already both at sof and bugzilla, but they were not assigned yet the last time I checked.

However from the info I gathered it appears to be a widespread issue for yoga/ideapad models and for some models there is a “test bios update” which “fixes” the issue. Now I’m not too comfortable with messing around with an unreleased bios patch to get it working and it is also not for the S740 model, so I guess its just a waiting game.

For those looking for a solution. A solution has just been found! On here there are two methods as of writing this. Either patch your own kernel with the script in this repo, or run the python script once in a while to awaken your speakers. Be sure you have alsa-tools installed.

Update, the patch has been submitted and is destined for kernel 5.13.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.