No sound on Creative AE-7 on Fedora 38

I recently bought a Creative AE-7 sound card and replaced the previously used Creative X-Fi Titanium sound card I had with this new AE-7.

I am using Fedora 38 rawhide. It has been installed/used over the last few months/maybe 1-2 years now and the X-Fi card worked properly on it. However, with this new AE-7, I don’t have any sound.
kmix shows the card, but no sound plays when I plug in the headphones on it.

The sound card is detected, the module seems to be loaded. However, something is not working properly as no sound is played using this.

I am quite disappointed as this seems to be a good sound card and I was eagerly expecting it to work better on Linux as compared to Windows. Windows sound is disappointing, but the Linux scenario is quite bleak with this problem.

Could someone please help me get the sound card working? I am not very well versed with this new sound card configuration method (not sure of the name as it does not appear to be alsa/pulseaudio)

I am fine with compiling the drivers from source if there is a need.
Any details you need, please do ask I will get it posted.


Welcome infantvin,

Creative Labs has never made any drivers for any of their products for Linux. The firmware and driver you were using with the X-Fi was created by a member of the community ‘Connor McAdams’. He has stated that he has no interest in building new firmware or drivers. I have this exact card. Hardware wise, it is a nice sound card.

Phoronix website claim it would be added to the 5.10 kernel, but seems to only work for the AE-5 and below.

I use my onboard built-in audio Realtek device when in Fedora Silverblue.

Until someone builds the firmware and drivers, this card will not work. Even on Ubuntu it will work in stereo mode, but as soon as you touch any sound settings it stops working.

Pipewire and Wireplumer are the packages you were probably referring to, but it can’t do anything without the drivers needed for it to function properly. I tried the flatpak package Helvum, dragging the connections around, but it still didn’t have any output.