No sound input on Acer Swift 3

Hello to all,

I’m very new to fedora, coming from years of manjaro and archlinux, and loving it so far.
I recently installed Fedora 39 on my Acer Swift 3, and everything works fine except for a few quirks.

My biggest issue is that my built-in microphone does not work, whereas it worked on my previous system. The sound card is a Intel Ice Lake - LP Smart Sound.
It is recognised by pavucrontrol as a digital microphone, but no sound is registered. Increasing the volume slider does not change anything.

Using an USB, jack or bluetooth microphone works as expected.
Sound output works as expected.

I’m not sure how to provide usefull informations to help troubleshoot this…

System Details Report


Report details

  • Date generated: 2024-04-03 10:34:42

Hardware Information:

  • Hardware Model: Acer Swift SF314-57
  • Memory: 8,0 GiB
  • Processor: Intel® Core™ i3-1005G1 × 4
  • Graphics: Intel® UHD Graphics (ICL GT1)
  • Disk Capacity: (null)

Software Information:

  • Firmware Version: V1.14
  • OS Name: Fedora Linux 39 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 45.5
  • Windowing System: Wayland
  • Kernel Version: Linux 6.7.11-200.fc39.x86_64

Thank you for your help !

Please, first make sure that your microphone has not been muted at the hardware level by the function keys.

Thank your for answering this quickly.

I have no function key allowing me to enable nor disable the microphone.

I tried a few things :

  1. I used Pavucontrol to check that the mic was enabled (which it was) and even toogled it a few times, to no avail.
  2. I set a keyboard shortcut to mute/unmute the mic in gnome-settings. Toogling works, correctly display the info pill “microphone muted / unmuted”, but does not change anything.
  3. I used amixer set Capture nocap and cap, but that did not change anything.

To be clear, Pavucontrol did see the change in status for the microphone every time, but i did not change the behavior of my system, meaning the capture level for the mic is still 0db.

Is there any command i can run or log i can read to help diagnose the problem ?