No sound in headphone, speaker works fine

In my asus zenbook, there is no sound from headphone.
In Setting-> Sound-> Output sound strength bar, it shows sound is there, but I can’t actually hear any:

I tried following How to debug sound problems - Fedora Project Wiki with no success.

  1. output -
  2. Removing Pulseaudio doesnt change the problem
  3. alsamixer -c0Pasteboard - Uploaded Image
  4. options snd_hda_intel model=(recommended parameter) I dont know the recommended option

I tried pulseaudio troubleshoot from arch also, with no help.

Update I have also found:

$cat /proc/asound/card0/codec* | \grep Codec
Codec: Realtek ALC295
Codec: Intel Kabylake HDMI


$cat /etc/modprobe.d/sound.conf 
options snd-hda-intel model=asus-zenbook

doesn’t help either.

Kindly help.

Could it be the same issue?

Probably…but I havn’t got the 2nd part of his output, with alsa lib-mixer. My alsactl restore is:

$alsactl restore
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
alsa-lib parser.c:260:(error_node) UCM is not supported for this HDA model (HDA Intel PCH at 0xef128000 irq 129)
alsa-lib main.c:1014:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6
Found hardware: "HDA-Intel" "Realtek ALC295" "HDA:10ec0295,10431740,00100002 HDA:8086280b,80860101,00100000" "0x1043" "0x1740"
Hardware is initialized using a generic method

In Settings i have no displayed headphones as Output Device. Not the same

Two questions: first, have you tried using a different set of headphones and second, have you tried connecting your headphones to a different jack, if your computer has one or a different computer? There’s always the possibility that either your headphones or the jack you’re using are bad, and if so, hunting for a software issue is a waste of time.

Headphone is working fine on other devices.
I have only one jack. If there is a problem in jack, how the soundbar is working, as shown in the picture?

Problem Solved. We have to choose Analogue Surround 2.1/4.0 Output in Configuration. Then its working fine.165ee40ff6ee07894fc42d023603385f6cdfcfd5.png

OK, we’ve eliminated hardware; good. And, as far as the jack goes, I had no way of knowing it was good until you told me.

Please check the image again. Its before you insert the headphone. In normal speaker mode, change the configuration. Then insert the headphone.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.