No sound from speakers after resume on Acer ZenBook UX325EA Tiger-Lake laptop

The sole frustration I have with Fedora Workstaton 39 on my Acer ZenBook UX325EA Tiger-Lake laptop is that I don’t have sound through speakers after resume.

Did anybody find a solution ? So far, I’m forced to reboot if I want to watch videos after resume.

$ inxi -A
 Audio:
   Device-1: Intel Tiger Lake-LP Smart Sound Audio
     driver: sof-audio-pci-intel-tgl
   Device-2: Conexant Systems (Rockwell) []
     driver: hid-generic,snd-usb-audio,usbhid type: USB
   API: ALSA v: k6.6.12-200.fc39.x86_64 status: kernel-api
   Server-1: PipeWire v: 1.0.1 status: active
alsa-lib-1.2.10-3.fc39.x86_64
alsa-ucm-1.2.10-3.fc39.noarch
pulseaudio-libs-16.1-5.fc39.x86_64
pulseaudio-libs-glib2-16.1-5.fc39.x86_64
gvncpulse-1.3.1-3.fc39.x86_64
alsa-firmware-1.2.4-10.fc39.noarch
alsa-tools-firmware-1.2.5-9.fc39.x86_64
alsa-utils-1.2.10-1.fc39.x86_64
wireplumber-libs-0.4.17-1.fc39.x86_64
wireplumber-0.4.17-1.fc39.x86_64
qemu-audio-alsa-8.1.3-1.fc39.x86_64
alsa-sof-firmware-2023.12-1.fc39.noarch
pipewire-alsa-1.0.1-1.fc39.x86_64
pipewire-pulseaudio-1.0.1-1.fc39.x86_64

I tried to use some module option : options snd-intel-dspcfg dsp_driver=1 and later on
options snd-hda-intel probe_mask=0x01 with no success.

If someone has some idea on how to fix it …

To clear obvious ones out, I would do the following steps.

Hi Hank.
Sound from speakers does work when starting the laptop.
No issue with audacious/youtube/speaker-test & co …
It’s just it does not work anyloger after sleep/resume.
Output device is still detected after resume but I get no sound.

I checked the links you mention but didn’t find a solution.

I wonder if the issue is not the ALC294 related .

Soud extra details :

$ journalctl -k | grep -Ei "ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel" 

févr. 18 12:53:01 killbill kernel: software IO TLB: area num 8.
févr. 18 12:53:01 killbill kernel: pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
févr. 18 12:53:01 killbill kernel: PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
févr. 18 12:53:01 killbill kernel: software IO TLB: mapped [mem 0x000000002faa6000-0x0000000033aa6000] (64MB)
févr. 18 12:53:01 killbill kernel: integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
févr. 18 12:53:01 killbill kernel: integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
févr. 18 12:53:01 killbill kernel: integrity: Loaded X.509 cert 'Huaqin NBD2 Software Certificate: 4672fbfc31a0ada6417c929fb7a3c1ba'
févr. 18 11:53:12 killbill kernel: snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
févr. 18 11:53:12 killbill kernel: snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: enabling device (0000 -> 0002)
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: use msi interrupt mode
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: hda codecs found, mask 5
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: DMICs detected in NHLT tables: 2
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
févr. 18 11:53:12 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
févr. 18 11:53:13 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
févr. 18 11:53:13 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
févr. 18 11:53:13 killbill kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Topology: ABI 3:22:1 Kernel ABI 3:23:0
févr. 18 11:53:13 killbill kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: Parent card not yet available, widget card binding deferred
févr. 18 11:53:13 killbill kernel: snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
févr. 18 11:53:13 killbill kernel: snd_hda_codec_realtek ehdaudio0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
févr. 18 11:53:13 killbill kernel: snd_hda_codec_realtek ehdaudio0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
févr. 18 11:53:13 killbill kernel: snd_hda_codec_realtek ehdaudio0D0:    mono: mono_out=0x0
févr. 18 11:53:13 killbill kernel: snd_hda_codec_realtek ehdaudio0D0:    inputs:
févr. 18 11:53:13 killbill kernel: skl_hda_dsp_generic skl_hda_dsp_generic: hda_dsp_hdmi_build_controls: no PCM in topology for HDMI converter 3
févr. 18 11:53:13 killbill kernel: input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input13
févr. 18 11:53:13 killbill kernel: input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input14
févr. 18 11:53:13 killbill kernel: input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input15

If you don’t get sound after resume from suspend, try reloading pipewire service by entering this command in terminal;

$ systemctl --user restart pipewire pipewire-pulse

and

$ systemctl --user daemon-reload

Check audio again. If that works, could anyone advise how to make the settings persist?

p.s.) I’m not familiar with the output you shared.

Thanks. Already tried with no success.
I see multiple posts mentioning sound not working with Asus/HP & Tiger Lake and Linux.
I hope the sof-audio-pci-intel-tgl realtek / sof-hda-dsp / ALC294 issue will be solved by a newer kernel.

What is weird is that I see that after suspend the card is stil listed :

 cat /proc/asound/cards
 0 [Audio          ]: USB-Audio - ASUS USB Audio
                      ASUS ASUS USB Audio at usb-0000:00:14.0-4.1.2, full speed
 1 [sofhdadsp      ]: sof-hda-dsp - sof-hda-dsp
                      ASUSTeKCOMPUTERINC.-ZenBookUX325EA_UX325EA-1.0-UX325EA

ALC28x/29X/303 are all buggy FWIS, Several bug reports and mixed results.

6.6.12-200.fc39.x86_64 can you try 6.7.4-x if it is available for you?

Thanks for your post. Just tried it - issue is still around when using 6.7.x kernel :

inxi -A
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  API: ALSA v: k6.7.4-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.3 status: active

I’ll be honest, You should file a bug :

https://bugzilla.redhat.com/index.cgi

and / or

https://bugzilla.kernel.org/

I know people don’t like to take the time out to do so, and some of it might be slightly cumbersome, but it’s really the way some of these issues get fixed.

If you had an event crash you could file a bug Easy Mode with Problem Reporting from Gnome Desktop.

but if you don’t, then filing one from those sites is a must.

If you need documentation or How-To here is a link from Fedora :

Thanks @hamrheadcorvette .
It took me some time but I created a bug : https://bugzilla.redhat.com/show_bug.cgi?id=2268707
Will update this page if a solution is proposed/found.

1 Like

I loose sound randomly after sleep/hibernate

Fix is to switch audio codect to other and then back to original what it was I usually do this on gnome settings

sometimes, the Gnome Logs has minor details the system does not have Priority on, there might be something there that can be associated to sound. If you find anything, add it to the bug report.

@phatle how do you switch codec ? I don’t see the option in Gnome settings ?

@hamrheadcorvette I don’t see any error at all in logs using journalctl

Configuration option does not exist on my Fedora 39.
I had hopes that kernel 6.8 will bring some improvement but this is not the case (last version tested so far is 6.8.6-200.fc39.x86_64)

Are you saying that Sound is now working, but you do not have Configuration option?

No : sound still does not work after suspend . I don’t have the Configuration field on my Workstation & SilverBlue devices in Sound Output. I upgraded both to Fedora 40. Issue is still around unfortunately.