No screen brightness problems in fedora

Hi, I recently installed Fedora and I came across a problem when setting the brightness, the night light mode works, but if I try to set the screen brightness in the terminal nothing happens, I tried using xbacklight and xrandr

pcilib: Error reading /sys/bus/pci/devices/0000:00:08.3/label: Operation not permitted
01:00.0 VGA compatible controller: NVIDIA Corporation GA107M [GeForce RTX 3050 Mobile] (rev a1)
Subsystem: Acer Incorporated [ALI] Device 159e
Kernel driver in use: nvidia

75:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt [Radeon 680M] (rev 0b)
Subsystem: Acer Incorporated [ALI] Device 159e
Kernel driver in use: amdgpu
video card information.

From Proposed Common Issues to Ask Fedora

Hello, what flavour of Fedora are you using? I believe your problems could be caused by your using Wayland and trying to manipulate the brightness settings with Xorg related commands that have no effect in this case.

You can either switch to Xorg, which you will do on the login screen. Check for a little cogwheel in the lower right corner (if it is not visible right away, it might appear after you have selected the user to log in) and select Gnome on X(org). Then your session will not use Wayland and you will be able to use the CLI commands of your choice.

A better practice, of course, would be to use Wayland related commands to do it. You could try installing and using the brightnessctl package. You could install this using the DNF command, such as sudo dnf install brightnessctl.

Unfortunately, I have never tried it, so I cannot give you the exact way of doing it. And I cannot try right now, because I only have a desktop here that is not capable of setting the display brightness. You can check the manual pages with man brightnessctl, they are quite explanatory.

Hi, I’m using Fedora 39, I switched from Fedora to xorg and changing the brightness through the terminal using the command “xrandr --output eDP --brightness 0.9” worked. Is there any way to enable the brightness bar via the “fn” shortcuts or on the side of the volume bar?