No run operating system

After installing Fedora 31 and operating system updates to the kernel
[[ kernel-5.4.12-200.fc31.x86_64 AND kernel-5.4.10-200.fc31.x86_64 ]],
the operating system will no run.

Are your’d updated from Fedora 30 to 31? Or it is fresh install?

How did your updated your machine (console, gnome-software)?

If Alt + Ctrl + F4 gives to your a working Kernel console, at least?

1 Like

fresh install.

after install default kernel is <<kernel-5.3.7-301.fc31.x86_64>> this kernel is work.

after update other kernel not load.

I had no problems with Fedora 29.

my system is lenovo ideapad 320-AST

1 Like

And what problem, errors, logs do you see?
The video is black?


does not show any errors. It’s just a black screen

Have you tried to boot into a live USB?

First, if your’ll wait for a 1-3 minutes (at the black screen of the new kernel), then press the above combination, do your see the console login prompt?

Second, do your use any proprietary drivers for your video card?

He did, indeed!


(post can’t be empty, post should be at least a 20 chars long)

after secure boot disabled in bios new kernel is loaded. :slight_smile:


Link to the twin-tread’s post-8. (Jan 28, 9:13 PM)
MS Bing machine translate:

hedayat (machine translate):
"This bug is not related to your problem apparently. The bug was before the release of Fedora 31 and the problem was resolved on the kernel of 5.2.
I am working with secure boot right now and I’m going to update the kernel and don’t have any problems.

As I said, it is better to take a log of the system to ascertain what is wrong.

However, if it is solved by disabling the secure boot, it is not bad to check for more accurate. Or you don’t report a bug. But by the way, a bug is referenced, and your problem is definitely not it."

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.