No permission to access /dev/ttyACM0 fedora 30 SB

Hi

I decided to go with fedora silverblue but now I have one little problem.
My CEC-Adapter isn’t working anymore. It used to work in fedora workstation.
In Kodi Log I get the following error:

ERROR: CecLogMessage - error opening serial port ‘/dev/ttyACM0’: Permission denied

In fedora 30 I got this fixed with:
$ sudo usermod -a -G dialout afrase

But that dosn’t work anymore.
Has anybody an advice?

Check the ownership of /dev/ttyACM0 and see if you can add yourself to the correct group:

  1. ll /dev/ttyACM0
  2. find out what group owns the file
  3. change your usermod command to match that group name

I’d also look at the permissions on the device it may be rw------- and not allow the group to read even if you’re a member.

The group permission is also read write:

crw-rw----. 1 root dialout 166, 0 8. Mai 19:30 /dev/ttyACM0

sudo usermod -aG dialout afrase groups
afrase wheel

As it seems I can’t add my user to that group “dialout”.

It may be you haven’t logged out. After changing that setting you have to log out and log back in again. You can confirm your membership by

sudo cat /etc/gshadow |grep dialout

This is the output.
dialout:::afrase

This is pretty lame and I’m not sure how it happened but that group being in only /etc/gshadow means normal users can’t read the file. The group definitions you want to use need to be in /etc/group. There are numerous groups in gshadow and not in group by default on silverblue. Not sure why yet. You can get everything working like this:

getent group dialout

This gave me the group and the id in the proper format your group id may be different

dialout:x:18

I then wrote the line with my user to the /etc/group file

dialout:x:18:myuser

Then restart. I can now access the devices owned by group dialout.

Awesome, that did the trick. Thank you very much! :partying_face: