No internet connection on Fedora 33

Hi there,

After upgrading from Fedora 32 to Fedora 33 my ethernet connection no longer works.
On startup I get an unexpected system error with the reason
“NETDEV WATCHDOG: enp38s0 (r8169): transmit queue 0 timed out”

My motherboard is an AsRock AB350 Gaming K4.

Running dmesg shows the following
[ 90.274455] r8169 0000:26:00.0 enp38s0: rtl_rxtx_empty_cond == 0 (loop: 42, delay: 100).
repeated a bunch of times.
Further up it also has the error
[ 79.013694] sp5100-tco sp5100-tco: Watchdog hardware is disabled
which may be related, I don’t know.

Try this:

Changing DNS with systemd-resolved | Enovision Notes

Interestingly, when I turned on my computer today, there was no problem. However, I will try your suggestion if it happens again.

Actually, it works, but it is super slow, I will try the suggestion.

Edit: @ilikelinux I tried your suggestion but it doesn’t seem to have done anything.

Slow is often related to the driver for the network card.
Please post the output of “inxi -Nxxn”

1 Like

@computersavvy The output I get is
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: c000
bus ID: 26:00.0 chip ID: 10ec:8168
IF: enp38s0 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:39:88:6f

The solution in this tread solved it for me:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.