No English layout when entering the login password|Unable to enter the # character


I made the mistake of setting # as an extra character in my login password.
The English layout just disappeared, although 2 days in a row I worked and logged in without problems, changing the padding when the input panel appeared.
I tried numerous ways to fix the situation yesterday, but so far with no success.
I’d love to hear any advice on this, maybe someone has already successfully fixed this bug.
I was also thinking about where to get a # sign from the real world, perhaps on some keyboard, or a specially bandaged button (would be glad if someone can suggest this).
Right now the problem is with the English layout, because when I type #, I’m entering a number sign.
And I need to insert the # sign either to change the layout from Ru to UK or another option to get the # sign

On a english (US) keyboard layout the # sign is the shifted number 3 key.
I don’t know what keyboard you use but that key is used a lot in things I do.

Note however that if it is used as the first character of something entered where the bash shell is involved it is interpreted as making the following string a comment.

As long as it is not the first character in the password that should not matter.