No display settings in Fedora 34 Cinnamon / HIDPI?

Due to some hardware limitations, I’m trying to get Fedora running through Parallels on my M1 Macbook Air, and trying out different DEs with it.

I prefer minimal installs, so chose that option when installing Fedora 34 (the 35 installer crashed). I was then able to install Cinnamon in one VM instance and Gnome in another.

Everything works as expected with Gnome, but I am unable to get any display settings in Cinnamon. Going to Settings > Displays just brings up a blank window for Layout, though there are some options under Settings.

I’m looking to change the resolution and scaling/HIDPI settings. I can change the resolution via CLI with xrandr, but have not been able to change the scaling. And I’d prefer the UI.

Note that I am able to change these settings in Gnome, as well as change these settings in Cinnamon with other distros (Debian, Ubuntu). Also note that I did a full install of Fedora using the recommended Parallels iso and had the same issue with Cinnamon.

Any ideas what I’m missing? Or how to successfully change the scaling? Setting the resolution to 2560x1600 without an accompanying scaling boost makes everything tiny. All my attempts to set the scale via xrandr leaves me with a black screen.


I was able to get display settings using VirtualBox on an x86 machine, so this appears to be specific to Parallels and/or aarch64.

I was able to get scaling to work via CLI with:
dconf write /org/cinnamon/desktop/interface/scaling-factor 'uint32 2'

Welcome to ask.:fedora: @sethleonard.

I do not use Parallels. But when I’m using Libwirt-Manager or Virtual-Box I have to switch on 3D Acceleration by the video settings. Otherwise i get an Error Message that Video problems can happen.
Can you check if you find this under Cinnamon and if this changes something if yo switch it on/off ?

Thanks @ilikelinux .

Unfortunately, turning on/off 3D acceleration doesn’t help. And I have the same VM config and base install for it and the Gnome version, which works fine. I also have the same config for Cinnamon Debian and it works fine. So I’m guessing I’m missing a package or a setting somewhere. I just don’t know where/what it is.

I’ve added a screenshot, in case it helps.

Or maybe there’s some incompatibility and different version will work, try Fedora respins ISO with latest updates applied:

I generally just make bigger fonts that i can make use of the new gained space from the bigger resolution.

Please do not compare what we do here with Debian, it is definitely not the same. Kernel and packages are mostly different/newer.

Not trying to compare, just isolate that I don’t think it’s Cinnamon-specific.