No Display on External Monitors with Docking Station | Fedora 40 | ThinkPad T14 | Intel TigerLake-LP GT2 [Iris Xe Graphics]

These are the configurations for my computer:

rabajaj@redhat:~$  inxi -Fzxx
System:
  Kernel: 6.8.7-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-34.fc40
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.41 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
Machine:
  Type: Laptop System: LENOVO product: 20W0003LUS v: ThinkPad T14 Gen 2i
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20W0003LUS v: SDK0J40697 WIN
    serial: <superuser required> part-nu: LENOVO_MT_20W0_BU_Think_FM_ThinkPad
    T14 Gen 2i UEFI: LENOVO v: N34ET61W (1.61 ) date: 03/08/2024
Battery:
  ID-1: BAT0 charge: 42.0 Wh (91.9%) condition: 45.7/50.5 Wh (90.6%)
    volts: 12.5 min: 11.5 model: SMP 5B10W51827 serial: <filter>
    status: discharging
CPU:
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
  Speed (MHz): avg: 499 high: 1197 min/max: 400/4700 cores: 1: 400 2: 400
    3: 400 4: 1197 5: 400 6: 400 7: 400 8: 400 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a49
  Device-2: IMC Networks Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-4:3 chip-ID: 13d3:5415
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: AU Optronics 0x408d res: 1920x1080 dpi: 158
    diag: 355mm (14")
  API: OpenGL v: 4.6 vendor: intel mesa v: 24.0.6 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
    device-ID: 8086:9a49
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
  API: ALSA v: k6.8.7-300.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15fc
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
    v: kernel pcie: speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
  IF: wlp9s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: virbr1 state: down mac: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 148.82 GiB (31.2%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 476.94 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 34.9 C
Partition:
  ID-1: / size: 97.87 GiB used: 33.41 GiB (34.1%) fs: ext4 dev: /dev/nvme0n1p4
  ID-2: /boot size: 973.4 MiB used: 280.3 MiB (28.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19.1 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 343.44 GiB used: 115.12 GiB (33.5%) fs: ext4
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 23.28 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p5
Sensors:
  Src: /sys System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.34 GiB used: 2.85 GiB (18.6%)
  Processes: 346 Power: uptime: 28m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 2 Compilers: gcc: 14.0.1 Shell: Bash v: 5.2.26
    running-in: gnome-terminal inxi: 3.3.34
rabajaj@redhat:~$ mokutil --sb-state
SecureBoot disabled
rabajaj@redhat:~$ dnf list installed \*nvidia\*
Installed Packages
akmod-nvidia.x86_64                                                                                                3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.8.7-300.fc40.x86_64.x86_64                                                                           3:550.76-1.fc40                                                                            @@commandline                   
nvidia-gpu-firmware.noarch                                                                                         20240410-1.fc40                                                                            @updates                        
nvidia-modprobe.x86_64                                                                                             3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                                                                                         3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                                                                             3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                                                                         3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                                                                                    3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                                               3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                 3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                                                                    3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                                                                                   3:550.76-1.fc40                                                                            @rpmfusion-nonfree-nvidia-driver

According to inxi you do not have an nvidia GPU, thus the nvidia drivers are useless.

Got it, I am not sure what to do here. Can you please guide what I must install and check for?

First test without connecting the docking station to see if an external monitor will function.

What has been noted by some is that fedora may not have the proper drivers for the docking station and thus will not properly support additional monitors.
You will need to confirm if this is a problem with the laptop or with the docking station before the problem can actually be narrowed down and find a fix.

You were right, I tried to connect my laptop directly with the monitor and it worked. However, with my docking stations it is not working. How can I install the proper drivers for the docking station?

Removed audio, flatpak, nvidia, pipewire, server, wireplumber

What Docking Station do you have? 3rd Party or Lenovo branded ?

I have a Lenovo Thinkpad Hybrid usb-c with usba-doc. Let me know if there is any command that I can run to show you more specific detail.

Here’s something funny, Install the dock, with the monitors.

In the terminal type fwupdmgr update then shutdown the computer. Restart and try the Monitors once again.

Supposedly the dock is very well supported for that device on Gnome.

The output of the command mentioned:

rabajaj@redhat:~$ fwupdmgr update
Devices with no available firmware updates: 
 • USB2.0 Hub
 • USB2.0 Hub
 • USB3.1 Hub
 • USB3.1 Hub
 • ThinkPad Hybrid USB-C with USB-A Dock
 • UEFI Device Firmware
 • UEFI Device Firmware
 • UEFI Device Firmware
 • UEFI Device Firmware
 • UEFI Device Firmware
 • vl105
Devices with the latest available firmware version:
 • Embedded Controller
 • Intel Management Engine
 • KXG6AZNV512G TOSHIBA
 • Prometheus
 • Prometheus IOTA Config
 • System Firmware
 • Unifying Receiver

Although after runner the above command and then restarting the machine, there was no change. Do we need to install these devices with latest available version?

Would have to look for the drivers, I have not come across anyone with that particular Dock + Issues. :thinking: some time here and see what we can dig up.


I need to step away and wont be back on till tomorrow, but I found this and a reliable repo I use myself “Negativo17” might come in handy ;

https://www.reddit.com/r/thinkpad/comments/t2tqje/lenovo_thinkpad_hybrid_usbc_with_usba_dock_is_not/

In past threads it seems this issue mostly is related to the way the monitors are detected.
The monitor must report the edid data to the system before the monitor can be configured and if that does not happen then the monitor is not properly configured.

Some docking stations seem to not provide that info properly from attached monitors and/or the monitor is not properly queried for its edid data.

How are the monitors attached?
How many monitors are attached to the docking station?
are the monitors and the docking station powered on before the laptop is booted?
If multiple monitors are attached to the docking station have you tried with only one monitor attached?

As root, I ran this command it worked for me :smile:

dnf config-manager --add-repo=https://negativo17.org/repos/fedora-multimedia.repo && dnf install -y displaylink

Thank you so much for all the help :slight_smile: really appreciate it! Both my monitors are working with the docking station now!

3 Likes