No AX200 Wifi device after Windows 11 update on dual boot

I have a dual boot workstation. I just booted into Windows 11 and updated it. After doing the updates and rebooting into Fedora 38 the OS no longer sees my Wifi network device (“Intel Wifi6 AX200 160 Mhz”) Working theory is that WIndows did something to the hardware and the OS no longer sees it. I see the Wifi hardware in the Windows device manager, but in Fedora lsusb only sees the bluetooth interface.

Any ideas how to “replumb” the Wifi interface?

SOLVED: Enable the “maximum performance” power plan in Windows 11. The go back to booting Fedora.

False alarm: “Fedora lsusb only sees the bluetooth interface.” This is normal… I see only “ID 8087:0029 Intel Corp. AX200 Bluetooth” normally.

NB: F38 filesystems are btrfs by default, so there is no way to mount them in Windows.

Well, that’s not a solution. After a few kernel upgrades (to 6.6.8-100) the wifi device was not present after rebooting from WIndows 11. Eventually I got it to work again after:

  • Rolling back and reinstalling the AX200 driver in Windows 11
  • Checking “All users may connect to this network” in Network Manager, which had somehow become unchecked.

Note that since my previous post had fastboot disabled and the Windows Power Plan set to “Maximum Performance”.

Maybe I’ll set the Fedora Energy Saving plan to “maximum performance” if this happens again. Right now it is set to “balanced”.

Hardware is a Beelink SER6 with AMI-type BIOS.

One thing that has been noted in the past is that windows may choose to block the wifi device, which can be seen in fedora with the rfkill command showing the device blocked. IIRC it shows up as HARD blocked, and fedora then cannot enable it nor use it.

If that is the case the user must, from within windows, ensure the device is enabled before shutting down windows. As long as windows has not blocked the device it usually is available for use by fedora. Sometimes the ‘fast boot’ setting within windows also may block the use of the wifi device.

Setting “maximum performance” worked a few times, then it didn’t.

What worked was disabling “fast boot” in the *** WIndows 11 settings *** not in BIOS.