No available ethernet on MSI Pro B660M-E (Intel I219-V)


I’ve assembled a machine featuring the mentioned motherboard. It has an ethernet controller, which is detected via lspci. It is enabled in the BIOS. Secure boot is off (though having it on made no difference for booting Fedora or this issue it seems). I’ve tried turning secure boot on and off and on and rebooting in between as I saw a mention of that making a difference.

The system is the current KDE live system, kernel 6.2.9

lspci -nnk | grep -A2 Ethernet yields:

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (17) I219-V [8086:1a1d] (rev 11)
        DeviceName: Onboard - Ethernet
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7d46]
        Kernel modules: e1000e

ip a shows only the loopback.

The motherboard has its newest BIOS ver. As I understand it this intel ethernet nic isn’t particularly new and support should be in the kernel. When an ethernet cable is plugged in the green and orange lights by the port light up; I have no current reason to suspect the port is somehow faulty). What further steps can I take to investigate/alleviate the issue? :slight_smile:

Hello @lampahojd ,
What do you see if you enter nmcli in a terminal, it should show any/all network connections Network Manager is handling.

Hi, it lists “lo”/loopback

lo: connected (externally) to lo
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536
        inet6 ::1/128
        route6 ::1/128 metric 256

and nothing more.

So Network Manager is not even looking at your wireless. I think you should be able to use nmcli device wifi connect ... but please try man nmcli-examples and man nmcli for greater details. Basically Network Manager seems to not be enabling your wireless device. This could be due to the hardware not being enabled for Network Manager to use.

Hi, there is no wireless on this matx mobo. Ethernet is enabled in the bios, I’ve never had to enable it elsewise (in any OS) and I have no notion of how that would work in Linux. Looking at the documentation of nmcli hasn’t yielded anything about enabling an interface (that it can’t see) I’m afraid.

I tried the latest Kubuntu live image just now and it is also 6.2 and it also sees no ethernet other than at a basic level (lspci). It’s likely some sort of BIOS or HW issue or a more general Linux / kernel 6.2 issue, the way I see it currently. The first options appears a bit unlikely as the port looks alive in the BIOS (the uefi stack for APX network boot an be enabled and becomes a boot option)…so it would be interesting to run Windows I guess as far as seeing whether it saw the ethernet interface.

Edit. So I installed Win 10 and no ethernet there either. The device manager reported that no driver was found for the ethernet controller. I installed the “complete driver pack” Intel® Ethernet Connection I219-V from there and then the ethernet interface appeared, operational. So what ever is in the Linux kernel isn’t enough it seems. There are .rpms in that archive. I’ll investigate further.

My bad, I thought you were having wireless issues. Even so, Network Manager should be finding the wired interface especially if it is common hardware. It would seem to be kernel module related, since the device wasn’t recognized by NM but lspci saw the hardware.

Well it’s working now in Fedora 38. I saw linux - How to repair the checksum of the non-volatile memory (NVM) of Intel Ethernet Controller I219-V of an ASUS laptop? - Super User , ran dmesg | grep e1000e and had exactly the same result as the OP there, “The NVM checksum is invalid”. The Intel archive I mentioned earlier refers to Intel Ethernet Drivers and Utilities download | just as parts of that thread, you apparently build it yourself.

I tried the two answers in a row employing bootutil64 but the util had no idea what “defaultconfig” was so I suppose one has to download the driver source from the above link and build the driver first, I didn’t think it evident from those two posts.

Before building the driver I followed the next reply and enabled the PXE (not APX, sorry about that) ethernet boot again in the BIOS then attempted to boot via its IPV4 and it found “media” it said and listed the nic’s mac I think and stalled (predictebly). A reboot into Fedora and presto, a functioning ethernet interface :slight_smile:

1 Like

Glad to hear you solved it.