No audio output on dock station (Dell) F34

Hello all,
OS is : Fedora 34
Hardware is : Dell XPS 13 9310 + Dell Thunderbolt Dock (WD19TBS)
Issue is : another Dock problem. For a few months everything worked nicely, but since a few weeks the audio output from the dock stopped working. I mean that if the Headphone - USB Audio or Line Out - USB Audio source are selected, no sound comes out.

Already tried with pavucontrol.
Already tried to update all firmwares.
It might happened after that a Windows machine was connected to the dock, but who knows… :man_shrugging:

On alsamixer the card is found… not an expert of audio drivers, so I’m not sure of which test I can give you to help understand the situation.

Many thanks if you have any suggestion!! :smiley:

Have you tried to boot in a older kernel?

Pipewire comes with some nice terminal commands who can help debug.

In terminal type pw- and then Tab 2 times:

pw-cat         pw-dump        pw-metadata    pw-mon         pw-reserve
pw-cli         pw-jack        pw-mididump    pw-play        pw-top
pw-dot         pw-link        pw-midiplay    pw-profiler    
pw-dsdplay     pw-loopback    pw-midirecord  pw-record   
pw-top shows what is running 
1 Like

btw the pipewire tools were not installed, weird, but cool that there is a “top” for audio driver. Since I cannot copy-paste from pw-top, I attach a screeshot of the output. Here I have selected as audio output the Line Out…

btw I’ve not tested yet to change kernel… I’ll test asap, but in the meantime if you have some insights, they are welcome

Is your firmware up to date:

Yes it was updated…
anyhow upgrading to Fedora 35 solved everything. For now it is solved.
(“For now” since on Fedora+XPS+dock setup, I periodically have some small issue like this, but since F35 everything is allright)

Hi all,

I have nearly the same hardware, F35, and the same issue - although this is a new issue for me.

OS : Fedora 35
Kernel : 5.15.12-200.fc35.x86_64
Pipewire : 0.3.40
Wireplumber : 0.4.5
Hardware : Dell XPS 13 9300 + Dell Thunderbolt Dock (WD19); all Dell firmwares are up to date and the latest version.

Issue is : Up to the last week/two weeks, everything worked nicely. I can’t tell exactly when the issue started as I use the dock on and off, but since very recently the audio output from the dock’s stopped working. Both the front headset output, and the rear output.

No issue whatsover with another work latop (Dell Latitude 7420) running Windows 10.

Any insight on how to debug this?

Maybe you could set the dock and run aplay -l. It will give you list of your cards like card 0: ..., device 0: .... Take a note the number of card and device.

Then run speaker-test -D hw:CardNumb,DevNumb -c 2 -l 1 /usr/share/sounds/Front_Center.wav. Replace hw:CardNumb,DevNumb with each cards and devices number you get from aplay -l. Take a note which card and device that give you a sound from the dock.

1 Like