No Audio Output - Intel Gemini Lake SOF Driver F36-Beta

I’ve got a sample laptop that I’m trying to get running on linux for an educational program. I’ve been able to get everything but the audio working (it has a touchscreen and can auto rotate). I’ve tried a few distributions including Ubuntu. I tried the Beta version with the hope that it would have the latest updates.
With a fresh install and updates it’s not showing an audio output in settings, and aplay -l has nothing.

I think I might need to file a bug report, but I wanted to check to see if there is a simple solution first. I’m not quite a Newbie, but my knowledge is spotty and I’ve still have a lot to learn. The post I found were for Tiger Lake hardware and were a few months old, so maybe I just need to configure some things. I’m willing to try things.

Here are a few outputs. (I also have the full alsa-info output, but wasn’t sure how to attach it.)

$ aplay -l
**** List of PLAYBACK Hardware Devices ****

Audio Section from lspci -vnn:

00:0e.0 Multimedia audio controller [0401]: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio [8086:3198] (rev 06)
DeviceName: Onboard - Sound
Subsystem: Device [1c6c:122a]
Flags: bus master, fast devsel, latency 0, IRQ 135
Memory at a1210000 (64-bit, non-prefetchable) [size=16K]
Memory at a1000000 (64-bit, non-prefetchable) [size=1M]
Kernel driver in use: sof-audio-pci-intel-apl
Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_apl

inxi -Fxz has more useful information.

$ inxi -Fxz
  Kernel: 5.17.4-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-24.fc36 Desktop: GNOME v: 42.0
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop Mobo: N/A model: N/A serial: <superuser required>
    UEFI: American Megatrends v: MSD-BI-11.6-S133GRX210-037-A date: 11/16/2021
  ID-1: BAT0 charge: 25.9 Wh (74.0%) condition: 35.0/35.0 Wh (100.0%)
    volts: 7.9 min: N/A model: N/A status: discharging
  Info: dual core model: Intel Celeron N4020 bits: 64 type: MCP
    arch: Goldmont Plus rev: 8 cache: L1: 112 KiB L2: 4 MiB
  Speed (MHz): avg: 1389 high: 1661 min/max: 800/2800 cores: 1: 1117
    2: 1661 bogomips: 4377
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: Alcor Micro USB 2.0 PC Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-8:4
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: i915 resolution: 1360x768~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.0.2
    direct render: Yes
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    driver: sof-audio-pci-intel-apl bus-ID: 00:0e.0
  Device-2: Alcor Micro USB 2.0 PC Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-8:4
  Sound Server-1: ALSA v: k5.17.4-300.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce v: N/A port: e000 bus-ID: 01:00.0
  IF: wlp1s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 57.62 GiB used: 3.75 GiB (6.5%)
  ID-1: /dev/mmcblk1 model: SLD64G size: 57.62 GiB
  ID-1: / size: 56.03 GiB used: 3.55 GiB (6.3%) fs: btrfs dev: /dev/mmcblk1p3
  ID-2: /boot size: 973.4 MiB used: 190.8 MiB (19.6%) fs: ext4
    dev: /dev/mmcblk1p2
  ID-3: /boot/efi size: 598.8 MiB used: 13.9 MiB (2.3%) fs: vfat
    dev: /dev/mmcblk1p1
  ID-4: /home size: 56.03 GiB used: 3.55 GiB (6.3%) fs: btrfs
    dev: /dev/mmcblk1p3
  ID-1: swap-1 type: zram size: 3.65 GiB used: 1.5 MiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 244 Uptime: 1h 0m Memory: 3.65 GiB used: 2.3 GiB (63.1%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.0.1 Packages: N/A
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.14